Bug 444765 - virtio_net driver causing hang at shutdown
virtio_net driver causing hang at shutdown
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 10:48 EDT by Mark McLoughlin
Modified: 2008-06-06 03:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.25.4-30.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-virtio_net-free-transmit-skbs-in-a-timer.patch (2.70 KB, patch)
2008-04-30 10:48 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2008-04-30 10:48:13 EDT
Running KVM guests with a virtio nic, I'm seeing a hang at shutdown at
"iptables: Unloading modules:"

Turns out nf_conntrack is blocking because virtio_net has left a TX skb dangling.

See:

  http://lkml.org/lkml/2008/4/30/207

Adding to F9Blocker because shutdown hangs suck and the fix seems fairly safe.
Comment 1 Mark McLoughlin 2008-04-30 10:48:13 EDT
Created attachment 304236 [details]
0001-virtio_net-free-transmit-skbs-in-a-timer.patch
Comment 2 Bug Zapper 2008-05-14 06:26:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Chuck Ebbert 2008-05-16 22:07:41 EDT
Did we get a better fix for this? Upstream didn't really like the proposed one...
Comment 4 Mark McLoughlin 2008-05-19 05:01:59 EDT
(In reply to comment #3)
> Upstream didn't really like the proposed one...

No, upstream wants to add a *host* feature to throttle tx notification
interrupts and have the guest detect when that feature is available. When it
isn't available, the guest will need to poll for tx completion in a timer.

So, upstream is going to merge my patch and later add the throttling feature to
the host and the guest-side code to take advantage of it:

  http://lkml.org/lkml/2008/5/19/26
Comment 5 Chuck Ebbert 2008-05-20 04:35:06 EDT
Patch in 2.6.25.4-29
Comment 6 Fedora Update System 2008-05-22 11:33:03 EDT
kernel-2.6.25.4-30.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-05-28 22:51:03 EDT
kernel-2.6.25.4-30.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4630
Comment 8 Fedora Update System 2008-06-06 03:44:08 EDT
kernel-2.6.25.4-30.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.