Bug 44479 - suck is out-of-date and history deduping doesn't work with inn
Summary: suck is out-of-date and history deduping doesn't work with inn
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: suck (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 51693
TreeView+ depends on / blocked
 
Reported: 2001-06-13 19:56 UTC by Jonathan Kamens
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 22:11:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file for building suck 4.2.5 (2.48 KB, text/plain)
2001-06-13 20:00 UTC, Jonathan Kamens
no flags Details
patch for making suck talk to the INN history database (1.44 KB, patch)
2001-06-13 20:01 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2001-06-13 19:56:11 UTC
The current version of suck is 4.2.5, but what RedHat is shipping is
4.2.4.  Also, the URL for suck in the RPM is wrong.  Also, neither 4.2.4
nor 4.2.5 will do history duplicate elimination properly, because the
message ID is no longer stored directly in the history file -- its hash is.

I'm going to attach two files -- a new spec file (if you use it, you'll
want to change the "Release" number to something other than "1jik") and a
patch to make suck use the INN libraries instead of reading the history
file directly.

Note that if you use my patch, the resulting suck binary will no longer
work against a non-INN history file.  If this is not acceptable, and it may
not be, then you may need to construct a suck RPM that has two different
suck binaries -- one with flat history file support and one with INN
history database support.

Comment 1 Jonathan Kamens 2001-06-13 20:00:46 UTC
Created attachment 21022 [details]
spec file for building suck 4.2.5

Comment 2 Jonathan Kamens 2001-06-13 20:01:21 UTC
Created attachment 21023 [details]
patch for making suck talk to the INN history database

Comment 3 Tim Powers 2001-10-01 14:54:41 UTC
I couldn't comment on this a while back, but it is now public knowledge that
Powertools has been discontinued. I am closing this as "won't-fix".

FWIW if we would have continued releasing Powertools I probably would have
incorporated the patch. 

Tim


Note You need to log in before you can comment on or make changes to this bug.