Bug 444797 - Gyachi - RPM gyachi-1.1.0-7.fc8.x86_64; webcam doesn't work
Gyachi - RPM gyachi-1.1.0-7.fc8.x86_64; webcam doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gyachi (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 13:03 EDT by Dave Krynick
Modified: 2013-03-13 01:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 19:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Krynick 2008-04-30 13:03:41 EDT
The RPM gyachi-1.1.0-7.fc8.x86_64 installs the webcam plugins to
/usr/lib64/gyachi. This seems to be correct, but when the webcam is started,
gyachi issues a message that it can't find /usr/lib/gyachi/gyachi/gyachi-upload
and/or can't find /usr/lib/gyachi/gyacgi-webcam. 

Obviously Gyachi is looking in the wrong place for the plugins. I don't know if
this is a problem with the RPM or with gyachi itself.

The quick work around is to create /usr/lib/gyachi and copy the folder and files
in /usr/lib64/gyachi to it. Since this is a very easy work around, the severity
and priority of the bug is even below low.
Comment 1 Rahul Sundaram 2008-04-30 21:59:49 EDT
Thanks for the report. The packaging is done correctly as per the Fedora
guidelines. Symlinks would cause other issues. The source hard codes some paths
which is problematic on x86_64. Specifically:

---
client/plugins.c in load_plugin_modules()
         snprintf(gbuff, 192, "%s/plugins", PACKAGE_LIB_DIR);

PACKAGE_LIB_DIR comes in configure.ac:

 ./configure.ac.tmpl:AC_DEFINE_UNQUOTED([PACKAGE_LIB_DIR],
"${acl_final_prefix}/lib/${PACKAGE}", [ Define for putting package-specific
shareable libs here ]
---

Gregory Hosler, do you want to fix the hardcoded paths in upstream and push a
new release? I could patch the file for now otherwise. 
Comment 2 Greg Hosler 2008-05-01 22:17:34 EDT
This is an interesting issue. I believe I can fix this in the source, with a new
configure switch, possibly with some spec file enhancements to use / set the
path or the x64 builds.

I am also working on updating fedora's gyachi to upstream level. The upstream
version has a number of enhancements that I would like to push into fedora. It
is also quite stable (having been in the wild for several months already, with
no complaints.)

There is also an issue w/ the fedora spec file not properly packaging the doc files.

I expect to push these all out sometime this month.

:)

-Greg
Comment 3 Fedora Update System 2008-05-20 12:19:13 EDT
gyachi-1.1.32-3.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-05-20 12:40:09 EDT
gyachi-1.1.32-3.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-05-21 06:56:04 EDT
gyachi-1.1.32-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gyachi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4168
Comment 6 Fedora Update System 2008-06-16 19:31:51 EDT
gyachi-1.1.32-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-06-16 19:33:08 EDT
gyachi-1.1.32-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.