Bug 444807 - Add GFS2 support for NFSv4 referral.
Add GFS2 support for NFSv4 referral.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Whitehouse
GFS Bugs
: Documentation, FutureFeature
Depends On: 433256
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 13:54 EDT by Rob Kenna
Modified: 2009-05-27 23:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 16:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Kenna 2008-04-30 13:54:10 EDT
NFSv4 provides for file delegation wherein a portion of an exported mount can be
redirected for service by an alternate system in the cluster.  bug 433256 asks
for GFS2 support and set lease support and has proposed patches.  This BZ is
intended for just the GFS2 portion.
Comment 1 Steve Whitehouse 2008-05-01 03:48:22 EDT
Why do we need this bug? So far as I know the original bug was all GFS2 stuff
anyway and the only reason that it hadn't been submitted was that it was
rejected from 5.2 so that it just needs resubmitting for 5.3 and the other bug
can be put back in POST. This one can probably be closed I think.
Comment 2 Rob Kenna 2008-05-01 07:36:46 EDT
I was under the impression that there was a bit of kernel work that was fs
generic and the the GFS2 (& GPFS) work was separate.  If I'm wrong on this count
I have no problem with closing this as a dup.

Note You need to log in before you can comment on or make changes to this bug.