Bug 444809 - Not able to sync rhel-i386-ws-4 channels from hosted.
Not able to sync rhel-i386-ws-4 channels from hosted.
Status: CLOSED CANTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Rel-Eng (Show other bugs)
rhn500
All Linux
high Severity high
: ---
: ---
Assigned To: Bryan Kearney
Amy Owens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 14:15 EDT by Preethi Thomas
Modified: 2013-01-10 04:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 15:30:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-04-30 14:15:16 EDT
Description of problem:
Not able to sync rhel-i386-ws-4 channels from hosted.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. from your satellite 
2. satellite-sync -crhel-i386-ws-4
3.
  
Actual results:
SYNC ERROR: unhandled exception occurred:

Exception reported from rlx-3-08.rhndev.redhat.com
Time: Wed Apr 30 13:41:05 2008
Exception type server.importlib.importLib.IncompatibleArchError

Expected results:

sync rhel-i386-ws-4

Additional info:

13:41:05 
SYNC ERROR: unhandled exception occurred:

Exception reported from rlx-3-08.rhndev.redhat.com
Time: Wed Apr 30 13:41:05 2008
Exception type server.importlib.importLib.IncompatibleArchError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 136, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 199, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 303, in _step_packages
    self._affected_channels = self.syncer.import_packages()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1604, in import_packages
    return self._link_channel_packages()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1628, in
_link_channel_packages
    importer = sync_handlers.link_channel_packages(uq_packages.values(), strict=0)
  File "/usr/share/rhn/satellite_tools/sync_handlers.py", line 407, in
link_channel_packages
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 592, in run
    self.fix()
  File "/usr/share/rhn/server/importlib/packageImport.py", line 73, in fix
    self.__copyChannels(package, package)
  File "/usr/share/rhn/server/importlib/packageImport.py", line 181, in
__copyChannels
    "Package arch %s incompatible with channel %s" %
IncompatibleArchError: Package arch x86_64 incompatible with channel rhel-i386-ws-4
Comment 1 Preethi Thomas 2008-04-30 14:29:13 EDT
I forgot to mention that I am syncing from webqa.
Comment 2 Grant Gainey 2008-04-30 15:30:17 EDT
Close can't fix - this is the same old problem, "WEBQA as an environment is
running on two zombie hamsters and an expended firecracker".  There isn't
anything RHN Hosted Engineering can do about that, and since we're the only
people that see BZs, I'm gonna close this one.

Perhaps opening a ticket, either to helpdesk@ or it-release-engineering@, would
be better.

Note You need to log in before you can comment on or make changes to this bug.