Bug 444815 - PVFB's NumLock doesn't stay in sync with host's
PVFB's NumLock doesn't stay in sync with host's
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
: 475213 (view as bug list)
Depends On:
Blocks: 514498
  Show dependency treegraph
 
Reported: 2008-04-30 15:05 EDT by Markus Armbruster
Modified: 2011-01-13 17:16 EST (History)
7 users (show)

See Also:
Fixed In Version: xen-3.0.3-111.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:16:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2008-04-30 15:05:42 EDT
Description of problem:
The guest's NumLock state can get out of sync with the host's.

Version-Release number of selected component (if applicable):
Last observed with kernel-xen-2.6.18-91.el5 in the guest, and xen-3.0.3-64.el5
in the host.

How reproducible:
Always

Steps to Reproduce:
1. Start PVFB guest, open its graphical console
2. Check status of guest NumLock (use gdm's user name entry to test), and status
of host NumLock in a suitable host window (e.g. terminal)
3. Toggle NumLock in the guest console window, check again
4. Toggle NumLock outside the guest console window, check again
  
Actual results:
Initial state of guest's NumLock may or may not match hosts.  Step 3 toggles
both host's and guest's NumLock.  Step 4 toggles only host's NumLock.

Expected results:
Initial state matches, and stays in sync through steps 3 and 4.
Comment 3 Miroslav Rezanina 2010-05-14 03:59:43 EDT
Partialy fixed by patch for bz #552612. However, there is errors in keyboard layout parsing to get NumLock synchronization to work properly.
Comment 11 Michal Novotny 2010-10-04 03:11:57 EDT
*** Bug 475213 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2011-01-13 17:16:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0031.html

Note You need to log in before you can comment on or make changes to this bug.