Bug 444824 - not all mkdumprd options work
not all mkdumprd options work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
: 445851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 16:35 EDT by Charlotte Richardson
Modified: 2010-10-22 20:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlotte Richardson 2008-04-30 16:35:50 EDT
Description of problem:
Two things:
1) /sbin/mkdumprd does not actually have --with-module, which presumably would
do what the extra_modules line in /etc/kdump.conf does. The only way to get
extra modules loaded by the kdump kernel is via /etc/kdump.conf.
2) /etc/kdump.conf does not expose an interface to /sbin/mkdumprd's --preload
<module> function, which would be extremely useful for us. It works fine if you
run /sbin/mkdumprd directly, and has the desired effect (the module loads before
the SCSI modules load).


Version-Release number of selected component (if applicable):
RHEL5.2 kernel build 89.


How reproducible:
Always

Steps to Reproduce:
Try /sbin/mkdumprd --with-module and --preload.
  
Actual results:
--with-module is not available. --preload works, but not from /etc/kdump.conf.


Expected results:
Would be really useful if both of these worked in both places.


Additional info:
Comment 1 Neil Horman 2008-05-09 10:38:41 EDT
*** Bug 445851 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Krafthefer 2008-05-22 12:09:29 EDT
This RFE has been reviewed during the RHEL RFE review
with Red Hat product management. This request has been *tentatively* approved
for inclusion
in the next update. This decision is not final and still pends further
technical review and scoping by Red Hat development engineering.
Comment 4 Neil Horman 2008-05-23 14:33:38 EDT
I've removed the --with-module option in 1.102pre-22.el5.  Note that the
extra_mods option in /etc/kdump.conf should provide you with the additional
functionality that --preload would otherwise provide.
Comment 8 errata-xmlrpc 2009-01-20 16:00:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0105.html

Note You need to log in before you can comment on or make changes to this bug.