Bug 444852 - Startup errors are not reported when --daemon option is used
Summary: Startup errors are not reported when --daemon option is used
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp   
(Show other bugs)
Version: beta
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
: ---
Assignee: Gordon Sim
QA Contact: Kim van der Riet
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-01 08:23 UTC by Gordon Sim
Modified: 2012-12-07 17:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gordon Sim 2008-05-01 08:23:50 UTC
I'm not seeing any error messages when starting up the broker in daemon mode.
E.g. if the port is already in use, the data directory does not exist or
whatver, no error message is printed but the broker does not start.

Comment 1 Gordon Sim 2008-05-13 12:59:55 UTC
This seems to be caused by -r649294 (I suspect the changes to Daemon.cpp):

http://svn.apache.org/viewvc/incubator/qpid/trunk/qpid/cpp/src/qpid/broker/Daemon.cpp?r1=649294&r2=649293&pathrev=649294

Comment 2 Gordon Sim 2008-05-13 16:46:28 UTC
Resolved by r655944 (http://svn.apache.org/viewvc?view=rev&revision=655944)

Comment 3 Mike Bonnet 2008-05-16 15:09:20 UTC
qpidc-0.2.656926-1.el5, qpidd-0.2.656926-1.el5, and rhm-0.2.2058-1.el5 have been pushed to the staging repo for testing


Note You need to log in before you can comment on or make changes to this bug.