Bug 444854 - ipa-server package does not require new enough python-configobj
ipa-server package does not require new enough python-configobj
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ipa (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 05:19 EDT by W. Michael Petullo
Modified: 2008-09-06 11:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-06 11:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2008-05-01 05:19:51 EDT
Description of problem:
I recently updated my ipa-server package to ipa-server-1.0.0-4.fc9.ppc using
yum. After the upgrade, ipa_webgui stopped working:

bash-3.2# ipa_webgui -d -f
failed to start web gui: ConfigObj>=4.3.2

I was using python-configobj-4.4.0-2.fc8.noarch. Manually upgrading to
python-configobj-4.5.2-1.fc9.noarch fixed the problem. Should the recent IPA
packages specifically require this new version of python-configobj?

Version-Release number of selected component (if applicable):
ipa-server-1.0.0-4.fc9.ppc

How reproducible:
Every time.

Steps to Reproduce:
See above.
  
Actual results:
See above.

Expected results:


Additional info:
Comment 1 Rob Crittenden 2008-05-01 09:01:30 EDT
Strange. 4.4.0 is >= 4.3.2 so I'm surprised you saw this error and that
upgrading fixed it.

python-configobj is a requirement of TurboGears and we let that manage its
dependencies.

This error should have been logged in /var/log/ipa_error.log as well. Are there
more details in there?
Comment 2 W. Michael Petullo 2008-05-01 10:10:03 EDT
Maybe there was something else wrong with the python-configobj package on my
system, though today is the first time I updated it in at least two months. This
is in my logs:

ERROR:root:failed to start web gui: ConfigObj>=4.3.2
  File "/usr/sbin/ipa_webgui", line 178, in <module>
    main()

  File "/usr/sbin/ipa_webgui", line 154, in main
    pkg_resources.require("TurboGears")

  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))

  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
Comment 3 Rob Crittenden 2008-05-01 10:53:24 EDT
You reference F-8 and F-9 packages. Which distribution are you on?

What version of TurboGears do you have installed?
Comment 4 W. Michael Petullo 2008-05-01 15:25:02 EDT
I have been using TurboGears-1.0.4.4-2.fc9.noarch. I do have a mixture of F-8
and F-9 packages. I installed F-8 on my computer and then have selectively
upgraded parts to F-9 for testing.
Comment 5 Rob Crittenden 2008-05-05 10:48:52 EDT
As a test, can you downgrade to python-configobj 4.4.0-2 and see if you can
replicate the error?
Comment 6 Bug Zapper 2008-05-14 06:27:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 W. Michael Petullo 2008-05-27 20:03:09 EDT
I finally had a chance to try this on a full Fedora 9 system.

I downgraded to python-configobj-4.4.0-2.fc8.noarch. None of the IPA packages complained about 
installing this package (I used the --oldpackage argument).

Once done, I see:

bash-3.2# ipa_webgui -d -f
failed to start web gui: ConfigObj>=4.3.2
Comment 8 Rob Crittenden 2008-05-28 09:11:07 EDT
The problem seems to be a packaging issue in python-configobj-4.4.0-2.fc8. It
doesn't include any egg-info so as far as I can tell doesn't provide any version
information. The full traceback is:

Traceback (most recent call last):
  File "/usr/sbin/ipa_webgui", line 178, in <module>
    main()
  File "/usr/sbin/ipa_webgui", line 154, in main
    pkg_resources.require("TurboGears")
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: ConfigObj>=4.3.2

This isn't something I can fix in IPA, even if I had an RPM requires on
python-configobj >= 4.3.2.

Assigning to owner of python-configobj.

While I agree that it is unusual to mix versions like this, should the F8
package provide egg-info?
Comment 9 Luke Macken 2008-05-28 11:39:58 EDT
F8 ConfigObj does not provide egg info, which is why we patch the F8 TurboGears
egg dependencies.  Since F9, all python packages produce egg info by default.

F8 and F9 TurboGears are both 1.0.4.4, so if you want to use F8 ConfigObj, use
F8 TurobGears.
Comment 10 W. Michael Petullo 2008-09-06 11:03:22 EDT
I set this to CLOSED WONTFIX, which is how I interpret the last comments.

Note You need to log in before you can comment on or make changes to this bug.