Bug 444867 - Add Remove Programs has no categories
Add Remove Programs has no categories
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 449714 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 07:48 EDT by Andrew Pitonyak
Modified: 2009-04-19 01:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-19 01:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Pitonyak 2008-05-01 07:48:34 EDT
Description of problem:
Add Remove has no Programs in categories

Version-Release number of selected component (if applicable):
Fedora 9 Live Persistence USB Key.

How reproducible:
I checked a few different categories

Steps to Reproduce:
1. Start a Live USB Key. I have not tried anything else.
2. Use System > Administration > Add/Remove Software to add new software.
3. Click on category on the left and no packages are listed.
  
Actual results:
No packages are listed

Expected results:
I expected packages to be listed in categories.

Additional info:
YUM works.
The updater works.
I saw a report that installing from here does not work.
http://forums.fedoraforum.org/showthread.php?t=187289
I applied a filter for openoffice, and software is shown as available for install.


Perhaps this bug is an extreme fix for bug 359211 :-)
Comment 1 Richard Hughes 2008-05-01 09:24:28 EDT
Are you using pirut or gpk-application?
Comment 2 Andrew Pitonyak 2008-05-01 18:21:12 EDT
Hmmm, I do not really know, but now that you ask, I expect that it is probably
gpk-application. 

I am using a stock Live disk with respect to what opens when I use Add/Remove
Software. Oops, sorry about that.
Comment 3 Andrew Pitonyak 2008-05-01 18:27:32 EDT
Received reply on the forums that leads me to believe that the issue is
repository based, not program based. I did not verify this yet.:
http://forums.fedoraforum.org/showthread.php?p=1004362#post1004362


You can solve this by:

;; "Adding the livna repository"
rpm -hiv http://rpm.livna.org/livna-release-8.rpm

;; "Disable the standard repo by setting enabled=0"
vi /etc/yum.repos.d/livna.repo

;; "Enable the development repo by settinge enabled=1"
vi /etc/yum.repos.d/livna-devel.repo


You can also use gedit instead of vi. More information is in the thread:

http://www.fedoraforum.org/forum/sh...ad.php?t=187319

Comment 4 Richard Hughes 2008-05-06 13:09:21 EDT
If you disable the livna repo, do the groups come back?
Comment 5 Tony 2008-05-09 22:19:39 EDT
My two cents. Had the same issue, click refresh application lists under System
fixed it for me.
Comment 6 Bug Zapper 2008-05-14 06:28:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Andrew McNabb 2008-05-14 14:50:47 EDT
I think I'm having the same problem with several different computers.  This is a
very strange problem.  Let me see if I can describe it.

I installed a new machine with Fedora 7.  I started Add/Remove Programs
(gpk-application).  If I click on Education, it says "Downloading lists", then
"Querying", and eventually prints "No results were found" in the right pane.

I then click on Fonts or Games or Graphics, and it starts Querying again for
about 10 seconds, and finally, "No results were found".

Then I go to the search bar and type a search keyword, like "python".  It starts
"Querying" and almost instantly starts showing results.

Then if I go back to Education or Games or any other category, it says
"Finished" in the status bar without even saying "No results were found" in the
right pane.

At some point, it started to work all on its own.  Just to see if I could make
it break again, I removed /var/cache/yum, and the problem came back.  By the
way, I also tried disabling the Livna repository, and that didn't help.  I
believe that the other machine with this problem never had Livna installed to
begin with.

Let me know if there's any more information I can give.
Comment 8 Andrew McNabb 2008-05-14 14:56:55 EDT
By the way, sometimes it works on its own randomly, and sometimes Refresh
Application Lists sometimes makes it work.
Comment 9 Andrew Pitonyak 2008-05-14 23:53:02 EDT
Using the actual live USB Key. I added the livna repository.

rpm -hiv http://rpm.livna.org/livna-release-9.rpm

Still no groups.

Use System > Refresh Application Groups (or something similar). The package
manager went out and downloaded the groups.

I believe that I simply needed to refresh the group lists. I consider this a bug
because the refresh should not have been required.
Comment 10 Richard Hughes 2008-06-04 04:02:50 EDT
*** Bug 449714 has been marked as a duplicate of this bug. ***
Comment 11 Keith Wilkinson 2008-06-25 01:52:19 EDT
449714 is a different bug : Several packages in the distro, like Tripwire, 
*can* be found by searching for them by name -- but they *don't* seem to appear
in any of the categories. 
Comment 12 Richard Hughes 2009-04-15 12:46:12 EDT
Should be fixed in Fedora 10, right?
Comment 13 Andrew Pitonyak 2009-04-19 01:38:41 EDT
Yes, I just verified that this is verified in Fedora 10. For future reference, is it acceptable if I then close this? I sure hope so, because I intend to do so!

Note You need to log in before you can comment on or make changes to this bug.