Bug 444875 - Duplex Tumble/No Tumble should handle portrait/landscape changes
Duplex Tumble/No Tumble should handle portrait/landscape changes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 09:20 EDT by Rodd Clarkson
Modified: 2008-05-14 06:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 23:13:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of how tumble/no tumble doesn't account for portrait/landscape (7.31 KB, application/vnd.oasis.opendocument.text)
2008-05-01 09:23 EDT, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2008-05-01 09:20:38 EDT
Description of problem:

I have a printer (Brother HL5250DN) that can print duplex.

The blank paper is inserted in the portrait position.

If I print a document with the pages set up to be portrait then I need to use
no-tumble on the duplex to get them to print correctly.

If I print a document with the pages set up to be landscape then I need to use
tumble on the duplex to get them to print correctly.

It I have a document (see attached example) that contains both portrait and
landscape pages, then it doesn't matter which setting I use (tumble or no
tumble) part of the document is going to print incorrectly.

cups should be smart enough to figure out that if the pages are landscape, then
the tumble/no tumble attribute needs to be toggled.  For example, I should be
able to leave the printer on no-tumble and have landscape just print correctly,
instead of having to remember the change the setting.  And in documents with
mixed page types, cups should be able to figure out what is right.


Version-Release number of selected component (if applicable):

[rodd@localhost ~]$ rpm -qa | grep cups
cups-libs-1.3.7-1.fc9.i386
libgnomecups-0.2.3-3.fc9.i386
hal-cups-utils-0.6.16-3.fc9.i386
bluez-utils-cups-3.30-2.fc9.i386
cupsddk-drivers-1.2.3-4.fc9.i386
cups-1.3.7-1.fc9.i386
[rodd@localhost ~]$ 


How reproducible:

Very

Steps to Reproduce:
1. See attached file
Comment 1 Rodd Clarkson 2008-05-01 09:23:20 EDT
Created attachment 304307 [details]
Example of how tumble/no tumble doesn't account for portrait/landscape

If I print this document on a duplexing printer with no-tumble set, then the
first two portrait style pages print with the heading up the top, but the two
landscape pages have their headings on the opposite sides of the page.

Change the printed to tumble and the first two pages are wrong, and the second
two are right.

Cups should be able to deal with this sort of thing intellegently.
Comment 2 Tim Waugh 2008-05-02 09:47:36 EDT
So, the document looks like this:

+----+
|1   |
|    |
|    |
+----+

+----+
|2   |
|    |
|    |
+----+

+------+
|3     |
|      |
+------+

+------+
|4     |
|      |
+------+

and the actual output when selecting "Long Edge (standard)" for the two-sided
option in the OpenOffice.org print dialog is like this:

sheet 1:
+----+     +----+
|1   |     |2   |
|    | <-> |    |
|    |     |    |
+----+     +----+

sheet 2:
+------+
|3     |
|      |
+------+
   ^
   |
   V
+------+
|4     |
|      |
+------+

It sounds like the output you're hoping for is this:

+----+     +----+
|1   |     |2   |
|    | <-> |    |
|    |     |    |
+----+     +----+

sheet 2:
+------+     +------+
|3     | <-> |4     |
|      |     |      |
+------+     +------+

Is that correct?
Comment 3 Rodd Clarkson 2008-05-03 04:30:48 EDT
Yeah, I'm pretty sure that what you're showing is what I'm expecting.

Simply, I would expect that if aligned the page appropriately and turned the
left side over to the right, then the page would still be aligned properly while
in a book.

Of course, along with this I would expect that a file formated like this

+---+
|1  |
|   |
|   |
+---+

+----------+
|2         |
|          |
+----------+

+----------+
|3         |
|          |
+----------+

+---+
|4  |
|   |
|   |
+---+

Would also see tumble/no tumble handled properly too.
Comment 4 Tim Waugh 2008-05-13 04:41:40 EDT
(In reply to comment #3)
> Simply, I would expect that if aligned the page appropriately and turned the
> left side over to the right, then the page would still be aligned properly while
> in a book.

I can't quite see what you're saying.  For a bound book, the sheets would all
need to be the same way round, with all the edges aligned, like this:

+----+
|+----+
||+----+
|||    |
+||    |
 +|    |
  +----+

If the book is bound on the left edge of the portrait-orientation pages, you
would surely want any landscape pages in the document to be readable by rotating
the book so that the bound edge is at the top of what you're reading (i.e.
rotating the book 90° clockwise).

It seems to me that's what we already have.  The pages are duplexed on the long
edge, i.e. the bound edge.

Can you explain again what you mean?
Comment 5 Rodd Clarkson 2008-05-13 23:13:26 EDT
Alright, I see what you mean and it makes sense.

Possibly the problem we're having is actually due to the complicated nature of
what we're trying to do and not an issue with printing.

My wife produces reports in OOo that are a combination of a document and a
spreadsheet.  Since we can't seem to incorporate the two, she has to print the
document with blank space (but with footers and headers including line numbers)
for the spread sheet and then print the spread sheet into the blank spaces
(manually taking out the pages and then reloading them into the printer).

I think the issue is that while she is setting up landscape pages in the
document (which is mostly portrait), cups sees this as a portrait document with
some landscape pages (and I suspect handles them appropriately).  But when we
print the spreadsheet, it's just landscaped pages on a landscape document (and
as this would have a different location for the 'spine' it prints them (again
right for the individual document) but not in the way we need them.

Argh, I hope that wasn't too confusing.  However, I'm confident that this is now
being handles right in terms of cups, so I'll close the bug.

I wish we could print a combination of documents and spreadsheets.

Comment 6 Bug Zapper 2008-05-14 06:28:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.