Bug 444878 - RHN repodata contains release "0" for every versioned Requires
RHN repodata contains release "0" for every versioned Requires
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
501
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
: 444739 448851 (view as bug list)
Depends On:
Blocks: 429320
  Show dependency treegraph
 
Reported: 2008-05-01 09:55 EDT by Pradeep Kilambi
Modified: 2010-10-22 20:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat502
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 17:13:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 James Antill 2008-05-01 10:02:23 EDT
*** Bug 444739 has been marked as a duplicate of this bug. ***
Comment 5 wes hayutin 2008-05-05 09:10:07 EDT
hrm.. looking at this.. I still see the release info rel=1.. so thinking it may
not be fixed

  <name>guile-devel</name>
    <arch>i386</arch>
    <version epoch="5" ver="1.8.0" rel="8.20060831cvs" />
    <checksum type="md5" pkgid="YES">1b59380626e5742700eb329d8bf9f2c4</checksum>
    <summary>Libraries and header files for the GUILE extensibility library.
</summary>
    <description>The guile-devel package includes the libraries, header files, etc.,
that you'll need to develop applications that are linked with the
GUILE extensibility library.

You need to install the guile-devel package if you want to develop
applications that will be linked to GUILE.  You'll also need to
install the guile package.
</description>
    <packager></packager>
    <url></url>
    <time file="1157468661" build="1157468661" />
    <size package="122907" installed="" archive="493340" />
    <location href="getPackage/guile-devel-1.8.0-8.20060831cvs.i386.rpm" />
    <format>
      <rpm:license>GPL</rpm:license>
      <rpm:vendor>Red Hat, Inc.</rpm:vendor>
      <rpm:group>Development/Libraries </rpm:group>
      <rpm:buildhost>hs20-bc1-7.build.redhat.com</rpm:buildhost>
      <rpm:sourcerpm>guile-1.8.0-8.20060831cvs.src.rpm</rpm:sourcerpm>
      <rpm:header-range start="440" end="24216" />
      <rpm:provides>
        <rpm:entry name="guile-devel" flags="EQ"                        
epoch="5" ver="1.8.0" rel="8.20060831cvs" />
      </rpm:provides>
      <rpm:requires>
        <rpm:entry name="rpmlib(CompressedFileNames)" flags="LE"               
         epoch="0" ver="3.0.4" rel="1" />
Comment 8 wes hayutin 2008-05-05 09:39:55 EDT
yum works for that package...
after reading some previous comments I thought the "rel=1" from
 <rpm:entry name="rpmlib(CompressedFileNames)" flags="LE"               
         epoch="0" ver="3.0.4" rel="1" />

should be removed.. but maybe thats not the case...


Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 guile-devel             i386       5:1.8.0-8.20060831cvs  rhel-i386-server-5  120 k
Installing for dependencies:
 gmp-devel               i386       4.1.4-10.el5     rhel-i386-server-5  522 k
 guile                   i386       5:1.8.0-8.20060831cvs  rhel-i386-server-5  1.4 M

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 2.0 M
Is this ok [y/N]: 

Downloading Packages:
(1/3): gmp-devel-4.1.4-10 100% |=========================| 522 kB    00:00     
(2/3): guile-1.8.0-8.2006 100% |=========================| 1.4 MB    00:00     
(3/3): guile-devel-1.8.0- 100% |=========================| 120 kB    00:00     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: guile                        ######################### [1/3] 
  Installing: gmp-devel                    ######################### [2/3] 
  Installing: guile-devel                  ######################### [3/3] 

Installed: guile-devel.i386 5:1.8.0-8.20060831cvs
Dependency Installed: gmp-devel.i386 0:4.1.4-10.el5 guile.i386 5:1.8.0-8.20060831cvs
Complete!
[root@test01-vmx yum]# 
Comment 9 wes hayutin 2008-05-05 10:11:32 EDT
verified..
Comment 10 Preethi Thomas 2008-05-16 09:26:04 EDT
release pending
Comment 11 wes hayutin 2008-05-20 17:13:07 EDT
5.0.2 Satellite is now GA, bugs Closed for Current Release.

Comment 15 Brandon Perkins 2008-12-23 12:01:11 EST
*** Bug 448851 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.