Bug 444892 - file subsystem lock up (affecting all partitions)
file subsystem lock up (affecting all partitions)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-01 12:02 EDT by Edek Pienkowski
Modified: 2009-01-09 01:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 01:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -vv (27.04 KB, text/plain)
2008-05-01 15:13 EDT, Edek Pienkowski
no flags Details
lsusb -vv (20.96 KB, text/plain)
2008-05-01 15:14 EDT, Edek Pienkowski
no flags Details
/proc/mdstat (519 bytes, text/plain)
2008-05-01 15:15 EDT, Edek Pienkowski
no flags Details

  None (edit)
Description Edek Pienkowski 2008-05-01 12:02:12 EDT
Description of problem:
file/disk/raid subsystem lock up
I am not a kernel hacker: everything that needs disk access freezes, other apps
such as gkrellm function ok. sync or reboot freezes too. Didn't try magic SysReq
I have four SATA drives, root on Raid1, home on raid5 (all software RAID with 4
partitions each)

Version-Release number of selected component (if applicable):
stock Fedora 8 kernel; same with 

How reproducible:
build kernel with 
nice -n 20 make -j12 
(failed 2 out of 3 times; however, I remember building it a few times with -j4
with no problems)

Steps to Reproduce:
1. COre 2 Quad; 4 SATA drives WD; root on raid1 home on raid5 (partitions of all
four drives)
2. build kernel with "nice -n 20 make -j12" on home (raid5)
3. failed 2/3.
Actual results:
Everything that needs disk freezes (it is bad; cleaning up the filesystems and
raid after this takes a lot of time)

Expected results:
No lock up

Additional info:
nothing in dmesg
What info do you need?
Comment 1 Dave Jones 2008-05-01 12:11:44 EDT
try running with the kernel-debug package installed for a while, and see if you
can repeat it with that.  Maybe lockdep will pick up something. (it's a stab in
the dark, but with no other info, there's not much else to suggest).

also echo T >/proc/sysrq-trigger will dump the process state to the dmesg
buffer.  It's quite large though, so it'll likely overflow, and as you can't
write to disk, syslogd is unlikely to help.   Hmm, echo S > /proc/sysrq-trigger
might be worth a shot, depending on how locked up the VFS is.

If you can set up a serial console or netconsole, that may be a better solution
to get everything out.  There's instructions for both at
Comment 2 Edek Pienkowski 2008-05-01 12:47:08 EDT
Now tried -j4, and during 2nd step it started dumping strange characters to my
terminal till it probably failed.

Running memtest... so far looks ok
Comment 3 Edek Pienkowski 2008-05-01 15:07:19 EDT
memtest ok.

After a few tries I put a new filesystem on home and restored from backup -
files must have been already corrupt (causing the strange chars problem), now it
compiled with -j4.

I tried netconsole (just to see it works before I actually need it) - and there
is a problem. Dumping tasks with sysrq didn't work - so I did "dmesg -n 8",
retried, and it did dump a few tasks, but froze the machine (mouse cursor was
moving, I could move windows with the mouse, but keyboard was dead - forgot to
check capslock however)

I'll post some system info, but I'll think twice and prepare before I think of
reproducing it again with -j12 - it takes a lot of time to restore the system
afterwards and netconsole is only partially working.

Anything else I could do? (every reproducing would take 1-2 hours of restoring
the system)
Comment 4 Edek Pienkowski 2008-05-01 15:13:50 EDT
Created attachment 304334 [details]
lspci -vv
Comment 5 Edek Pienkowski 2008-05-01 15:14:29 EDT
Created attachment 304335 [details]
lsusb -vv
Comment 6 Edek Pienkowski 2008-05-01 15:15:03 EDT
Created attachment 304336 [details]
Comment 7 Bug Zapper 2008-11-26 05:37:13 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2009-01-09 01:27:27 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.