Bug 444913 - web traceback on using wrong reactivation keys
web traceback on using wrong reactivation keys
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Justin Sherrill
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 15:23 EDT by Preethi Thomas
Modified: 2009-03-23 22:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 16:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-05-01 15:23:24 EDT
Description of problem:
no error message only web traceback on using wrong reactivation keys

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. register 2 systems (system1 & system2) and give provisioning entitlements.
2 create reactivation keys for both the systems
3. reactivate system1 with the reactivation key of system2.
 observe that there is no error message. but there is a web traceback email.
  
Actual results:
 
no error message only web traceback email

Expected results:

Error message.
Additional info:
org.quartz.JobExecutionException: com.redhat.rhn.common.db.WrappedSQLException:
ORA-00932: inconsistent datatypes: expected UDT got CHAR
 [See nested exception: com.redhat.rhn.common.db.WrappedSQLException: ORA-00932:
inconsistent datatypes: expected UDT got CHAR
]
	at com.redhat.rhn.task.ErrataMailer.execute(ErrataMailer.java:108)
	at
com.redhat.rhn.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:50)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
* Nested Exception (Underlying Cause) ---------------
com.redhat.rhn.common.db.WrappedSQLException: ORA-00932: inconsistent datatypes:
expected UDT got CHAR

	at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
	at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
	at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:216)
	at
oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:955)
	at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1168)
	at
oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3285)
	at
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3390)
	at
com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:1908)
	at
com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:133)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:444)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:421)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:265)
	at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:28)
	at com.redhat.rhn.task.ErrataMailer.populateWorkQueue(ErrataMailer.java:226)
	at com.redhat.rhn.task.ErrataMailer.sendEmails(ErrataMailer.java:166)
	at com.redhat.rhn.task.ErrataMailer.execute(ErrataMailer.java:87)
	at
com.redhat.rhn.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:50)
	at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
Caused by: java.sql.SQLException: ORA-00932: inconsistent datatypes: expected
UDT got CHAR

	... 21 more
Comment 1 Preethi Thomas 2008-05-01 16:14:13 EDT
I think the web trace back was not becuause of the reactivation problem.


Description of problem:
no error message on using wrong reactivation keys

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. register 2 systems (system1 & system2) and give provisioning entitlements.
2 create reactivation keys for both the systems
3. reactivate system1 with the reactivation key of system2.
 observe that there is no error message. but there is a web traceback email.
Comment 3 Justin Sherrill 2009-03-13 16:23:28 EDT
Neither myself nor Preethi can seem to reproduce.  Closing...

Note You need to log in before you can comment on or make changes to this bug.