Bug 444929 - system-config-printer scriptlet error and segfault
system-config-printer scriptlet error and segfault
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
9
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-01 21:09 EDT by Neal Becker
Modified: 2008-07-22 09:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 09:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-05-01 21:09:07 EDT
Description of problem:

pgrading system-config-printer-0.7.82.2-1.fc9.x86_64
error: %postun(avahi-0.6.17-1.fc7.x86_64) scriptlet failed, exit status 1
/var/tmp/rpm-tmp.16591: line 12: 18014 Segmentation 
fault      /usr/bin/xmlcatalog --sgml --noout --del /etc/sgml/ca\
talog "/etc/sgml/docbook-slides.cat"
Traceback (most recent call last):
  File "/usr/share/system-config-firewall/convert-config", line 30, in 
<module>
    from fw_config import *
  File "/usr/share/system-config-firewall/fw_config.py", line 31, in <module>
    from netconfpkg import NCDeviceList
  File "/usr/share/system-config-network/netconfpkg/__init__.py", line 61, in 
<module>
    exec _cmd
  File "<string>", line 1, in <module>
  File "/usr/share/system-config-network/netconfpkg/Control.py", line 29, in 
<module>
    import NCDeviceList
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 26, 
in <module>
    from netconfpkg.NCDeviceFactory import getDeviceFactory
  File "/usr/share/system-config-network/netconfpkg/NCDeviceFactory.py", line 
74, in <module>
    from netconfpkg.plugins import *
  File "/usr/share/system-config-network/netconfpkg/plugins/__init__.py", line 
35, in <module>
    exec _cmd
  File "<string>", line 1, in <module>
  File "/usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py", line 
22, in <module>
    from netconfpkg.NC_functions import CTC
ImportError: cannot import name CTC
error: %trigger(system-config-firewall-1.2.7-1.fc9.noarch) scriptlet failed, 
exit status 1
/var/tmp/rpm-tmp.69171: line 12: 20184 Segmentation 
fault      /usr/bin/xmlcatalog --sgml --noout --del /etc/sgml/ca\
talog "/etc/sgml/docbook-simple.cat"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Poelstra 2008-05-02 18:00:57 EDT
Please provide more information as to what you were doing when this error
occurred as well as suggestions on how to reproduce it.  Thank you
Comment 2 Neal Becker 2008-05-02 20:03:41 EDT
Upgrading system from F8 -> rawhide using preupgrade.
Comment 3 Thomas Woerner 2008-05-04 05:53:40 EDT
There is a problem in an imported module:

File "/usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py", line 
22, in <module>
    from netconfpkg.NC_functions import CTC
ImportError: cannot import name CTC

Assigning to system-config-network.
Comment 4 Harald Hoyer 2008-05-05 01:57:11 EDT
what is the output of:
$ rpm -qf /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py
??
Comment 5 Neal Becker 2008-05-05 08:17:02 EDT
rpm -qf /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py
error: file /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py:
No such file or directory
Comment 6 Harald Hoyer 2008-05-05 08:59:23 EDT
Hmm, maybe a *.pyc file left??

$ rpm -qf /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py*
Comment 7 Neal Becker 2008-05-05 09:09:11 EDT
rpm -qf /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py*
error: file /usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py*:
No such file or directory
Comment 8 Harald Hoyer 2008-05-05 09:21:43 EDT
 File "/usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py", line 
22, in <module>
    from netconfpkg.NC_functions import CTC

Did you change your system meanwhile? If so, does the problem persist?
Comment 9 Harald Hoyer 2008-05-05 09:22:44 EDT
$ rpm -qa system-config-network\*
Comment 10 Neal Becker 2008-05-05 09:39:54 EDT
rpm -qa system-config-network\*
system-config-network-1.5.7-1.fc9.noarch
system-config-network-tui-1.5.7-1.fc9.noarch
Comment 11 Neal Becker 2008-05-05 09:43:40 EDT
(In reply to comment #8)
>  File "/usr/share/system-config-network/netconfpkg/plugins/NCDevCTC.py",
line 
> 22, in <module>
>     from netconfpkg.NC_functions import CTC
> 
> Did you change your system meanwhile? If so, does the problem persist?

Not intentionally.  I don't think the problem persists.
Comment 12 Harald Hoyer 2008-05-05 10:38:24 EDT
so, the problem was during installation.

error 1:
error: %postun(avahi-0.6.17-1.fc7.x86_64) scriptlet failed, exit status 1
/var/tmp/rpm-tmp.16591: line 12: 18014 Segmentation fault     
/usr/bin/xmlcatalog --sgml --noout --del /etc/sgml/catalog
"/etc/sgml/docbook-slides.cat"

error2:
/usr/share/system-config-firewall/convert-config

runs while there are still old files around from s-c-network, and the new files
installed.
Comment 13 Harald Hoyer 2008-05-05 10:55:59 EDT
nothing s-c-network can do/fix...
Comment 14 Bug Zapper 2008-05-14 06:30:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Thomas Woerner 2008-07-22 09:09:21 EDT
I am sorry, but there is nothing we can do about this. I can not reproduce this
at all.

Note You need to log in before you can comment on or make changes to this bug.