Bug 444930 - Red Hat MRG docs page invalid html (missing closing li tag)
Summary: Red Hat MRG docs page invalid html (missing closing li tag)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Documentation   
(Show other bugs)
Version: beta
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Joshua Wulf
QA Contact: Kim van der Riet
URL: http://www.redhat.com/docs/en-US/Red_...
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-02 01:17 UTC by Wade Mealing
Modified: 2014-10-19 22:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 00:16:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2008-05-02 01:17:56 UTC
Description of problem:

Realtime docs page has missing closing </li> element, makes fonts look silly.

Version-Release number of selected component (if applicable):

visble on Fri May 2 2008, GMT +10 at 11:00 AM


How reproducible:

Every time.

Steps to Reproduce:
1. Visit MRG site
2. Note that the last option is tiny.
3. View source code, note missing li.
  
Actual results:

Font for Realtime Deployment GuidePDF (yes, without the space) is tiny, because
it is a sub LI of the previously broke li.

It is this:

<ul>
	<li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Installation_Guide/">Installation
Guide</a><small> <a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Messaging_Installation_Guide/Messaging_Installation_Guide.pdf">PDF</a></small></li>

	<li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Tutorial/">Messaging
Tutorial</a><small> <a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Messaging_Tutorial/Messaging_Tutorial.pdf">PDF</a></small></li>

</ul>

<h2 style="background-color:#ccc;">MRG Grid</h2>       
        <ul>
          <li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Grid_Deployment_Guide/ ">Grid
Deployment Guide</a> <small><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Grid_Deployment_Guide/Grid_Deployment_Guide.pdf">PDF</a>

        </ul> 

But should be

<ul>
	<li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Installation_Guide/">Installation
Guide</a><small> <a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Messaging_Installation_Guide/Messaging_Installation_Guide.pdf">PDF</a></small></li>

	<li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Messaging_Tutorial/">Messaging
Tutorial</a><small> <a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Messaging_Tutorial/Messaging_Tutorial.pdf">PDF</a></small></li>

</ul>

<h2 style="background-color:#ccc;">MRG Grid</h2>       
        <ul>
          <li><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Grid_Deployment_Guide/ ">Grid
Deployment Guide</a> <small><a
href="/docs/en-US/Red_Hat_Enterprise_MRG/1.0/pdf/Grid_Deployment_Guide/Grid_Deployment_Guide.pdf">PDF</a>
</li>

        </ul> 




Expected results:

Red Hat to validate to open standards.

Comment 1 Joshua Wulf 2008-05-02 02:34:39 UTC
I've fixed this in the web cvs. It should be visible on redhat.com in the next
day or two.

Comment 2 Wade Mealing 2008-05-02 02:38:59 UTC
Thankya

Comment 3 Lana Brindley 2008-05-06 00:06:06 UTC
This issue is still appearing, although from what I can tell the HTML is now
correct. Can someone take a look for me please? 

LKB

Comment 4 Joshua Wulf 2008-05-20 00:16:15 UTC
There was a missing </small> tag as well. It's fixed now.


Note You need to log in before you can comment on or make changes to this bug.