Bug 444948 - repodiff doesn't delete old data in the repos. it creates
repodiff doesn't delete old data in the repos. it creates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 05:31 EDT by Jan Hutař
Modified: 2010-10-22 20:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-05-02 05:31:49 EDT
Description of problem:
repodiff do not outputs expected changes.


Version-Release number of selected component (if applicable):
yum-utils-1.1.10-9.el5.noarch


How reproducible:
always


Steps to Reproduce:
1. # yum list available --disablerepo=\* --enablerepo=test1
2. # yum list available --disablerepo=\* --enablerepo=test2
3. # repodiff --old=file:///tmp/test1/ --new=file:///tmp/test2/


Actual results:
# yum list available --disablerepo=\* --enablerepo=test1
...
somepackage.i386                         0.2-2                  test1           
test-exclude.i386                        0.2-2                  test1           
test-obsoleted.i386                      0.1-1                  test1           
test-obsoletes.i386                      0.1-1                  test1           
test-only-new.i386                       0.2-2                  test1           
test-regular.i386                        0.2-2                  test1
# yum list available --disablerepo=\* --enablerepo=test2
...
somepackage.i386                         0.1-1                  test2           
test-exclude.i386                        0.1-1                  test2           
test-obsoleted.i386                      0.1-1                  test2           
test-obsoletes.i386                      0.1-1                  test2           
test-regular.i386                        0.1-1                  test2
# repodiff --old=file:///tmp/test1/ --new=file:///tmp/test2/
...
setting up old repo file:///tmp/test1/
0 packages excluded due to repository protections
setting up new repo file:///tmp/test2/
0 packages excluded due to repository protections
performing the diff
0 packages excluded due to repository protections
0 packages excluded due to repository protections


Expected results:
should show differences between these two repos
Comment 3 RHEL Product and Program Management 2008-09-25 09:25:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 James Antill 2008-09-29 01:08:45 EDT
 Sorry, I didn't spot this in your comment #9. From repodiff --help:

          -a ARCHLIST, --archlist=ARCHLIST
                In addition to src.rpms, any arch you want to include

...so with the above two repos. (which just have .noarch packages) you want:

repodiff -a noarch \
-o http://honeypot.usersys.redhat.com/yum/ \
-n http://honeypot.usersys.redhat.com/yum2/

...you still need the patch in yum-utils-1.1.16-8.el5.noarch or the time comparison does weird things, but the above should clear the confusion up, no?:)
Comment 20 errata-xmlrpc 2009-01-20 17:05:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0227.html

Note You need to log in before you can comment on or make changes to this bug.