This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 444997 - for every update the catalog shows postdate group removed
for every update the catalog shows postdate group removed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: web site (Show other bugs)
2
All Linux
high Severity low
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 13:09 EDT by Rob Landry
Modified: 2008-06-23 03:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: (2.18rh) 2008/05/23 push
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 03:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch to fix this bug and do some code-optimization (5.41 KB, patch)
2008-05-12 21:44 EDT, XINSUN
no flags Details | Diff
Delete the error mechanism when it can't figure out the group, becuase the group exists by default in bug db and can always be figured out . (5.29 KB, patch)
2008-05-13 23:42 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description Rob Landry 2008-05-02 13:09:01 EDT
Description of problem:

for every update the catalog seems to be calling the bz event logger and is
creating records of the postdate group being removed even if it wasn't set to
begin with.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 XINSUN 2008-05-12 21:44:22 EDT
Created attachment 305191 [details]
The patch to fix this bug and do some code-optimization
Comment 2 Rob Landry 2008-05-13 12:32:34 EDT
+    #If failed to find the hwcert_postdate group ID, indicate that group
dosen't exist.Then return

Doesn't actually indicate anything to the user, as such silent failure is a bad
thing; we should investigate where this happens in the code to see if it should
error out or just bail on this one thing.

+    #Set/Reset the post-date 

Do we really want it to not set the group but set the date?  This may be a
reasonable feature I don't know about the data integretity that BZ might attempt
to enforce.

sub UnsetPostDate {

Should likely have the same error mechanism as setPostDate does for when it
can't figure out the group.
Comment 3 XINSUN 2008-05-13 23:42:28 EDT
Created attachment 305325 [details]
Delete the error mechanism when it
can't figure out the group, becuase the group exists by default in bug db and can always be figured out .
Comment 4 Rob Landry 2008-05-16 11:44:49 EDT
Looks good on the surface, if this works properly when tested go ahead and check
it in.
Comment 5 XINSUN 2008-05-16 12:36:34 EDT
Have tested well, The patch have checked into cvs.
Nicho

Note You need to log in before you can comment on or make changes to this bug.