Bug 445048 - All resolutions are two lines too low.
All resolutions are two lines too low.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-02 18:47 EDT by Björn Persson
Modified: 2008-07-25 14:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 14:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configuration after selecting 1600×1200 in system-config-display (674 bytes, text/plain)
2008-05-03 14:48 EDT, Björn Persson
no flags Details
log with the attached xorg.conf (75.63 KB, text/plain)
2008-05-03 14:49 EDT, Björn Persson
no flags Details
log with no xorg.conf (47.39 KB, text/plain)
2008-05-03 14:51 EDT, Björn Persson
no flags Details

  None (edit)
Description Björn Persson 2008-05-02 18:47:57 EDT
Description of problem:
My graphics controller is the X3500 inside Intel's G35 chip on an Asus P5E-V
HDMI motherboard. X uses the driver "intel". The monitor is connected by DVI
through an HDMI-to-DVI adapter. The monitor always reports that the signal is
two pixels smaller vertically than it's supposed to be, regardless of which
resolution I choose in system-config-display. If I set the resolution to
1920×1200 the monitor reports 1920×1198, if I set 1680×1050 I get 1680×1048, and
so on all the way down to 640×480 which becomes 640×478.

Judging by what the Gnome panels look like and how far up and down the mouse
cursor will go, it looks like the logical size of the desktop is what it's
supposed to be, but the uppermost and the lowest line of pixels aren't displayed.

The problem occurs only in graphical mode on the DVI channel. In text mode I get
640×480 pixels, and with an analog connection instead of DVI I get the
resolution I set.

I have attached the monitor to another computer (with a graphics controller from
Nvidia), and got 1920×1200 pixels displayed. I have also attached another
monitor to the G35, and that monitor reported "resolution: new mode", indicating
that it too got some unusual resolution. These tests show that the problem is
with the G35 or the driver for it.

Two missing lines of pixels wouldn't be a big problem in itself, but the odd
resolution of 1920×1198 happens to trigger a bug in my monitor and as a result
the highest resolution I can use is 1600×1200 (which becomes 1600×1198). If I
could get the resolution I specify I'd be able to make use of the full width of
1920 pixels of my monitor.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-7.fc8
xorg-x11-server-Xorg-1.3.0.0-44.fc8

How reproducible:
always
Comment 1 Matěj Cepl 2008-05-03 03:58:40 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Björn Persson 2008-05-03 14:48:27 EDT
Created attachment 304463 [details]
configuration after selecting 1600×1200 in system-config-display
Comment 3 Björn Persson 2008-05-03 14:49:59 EDT
Created attachment 304464 [details]
log with the attached xorg.conf
Comment 4 Björn Persson 2008-05-03 14:51:41 EDT
Created attachment 304466 [details]
log with no xorg.conf

Restarting X without an xorg.conf gave me 1920×1198 pixels.
Comment 5 Björn Persson 2008-05-09 18:09:27 EDT
Am I supposed to change the status to something other than NEEDINFO when I've
provided the requested information? I've never found any instructions on how to
interact with developers through Bugzilla, so I don't know if reporters are
allowed to change the status of bugs as they see fit or if that should be left
to the developers. I'm changing the status to ASSIGNED now. I hope that's the
right status.
Comment 6 Matěj Cepl 2008-05-14 02:56:39 EDT
When you post any comment to the bug NEEDINFO is released? Unfortunately there
is a bug in bugzilla, that mere posting an attachment doesn't count.
Comment 7 Björn Persson 2008-05-14 18:38:31 EDT
I see. Apparently posting an attachment and a comment together, like I did in
comment 4, doesn't count either.
Comment 8 Matěj Cepl 2008-05-16 19:02:13 EDT
(In reply to comment #7)
> I see. Apparently posting an attachment and a comment together, like I did in
> comment 4, doesn't count either.

Yes, unfortunately so -- your comment is considered a description of the
attachment not a separate item. See bug 213941.
Comment 9 Björn Persson 2008-05-26 18:40:27 EDT
This problem is present in Fedora 9 too, with these package versions:
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.x86_64
Comment 10 Björn Persson 2008-07-25 14:56:07 EDT
This problem seems to be fixed with the recent X updates.

CURRENTRELEASE looks like the most appropriate resolution.

Note You need to log in before you can comment on or make changes to this bug.