Bug 445132 - Starting game dims screen
Starting game dims screen
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: armacycles-ad (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 07:16 EDT by Christopher Tubbs
Modified: 2009-02-03 09:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 09:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2008-05-04 07:16:50 EDT
Description of problem:
Starting up the game, whether in fullscreen mode or windowed mode, dims screen
brightness, whether plugged in to A/C power or running on battery.

Version-Release number of selected component (if applicable):
armacycles-ad-0.2.8.2.1-6.fc9.i386

How reproducible:
Every time I start the game.

Steps to Reproduce:
1. Install game
2. Start game
  
Actual results:
Screen dims upon game start

Expected results:
Screen should maintain brightness set by O/S

Additional info:
F9-preview on Dell E1405 laptop.

Output of /sbin/lsmod:

Module                  Size  Used by
autofs4                20356  2 
fuse                   41116  3 
ipt_REJECT              6784  2 
nf_conntrack_ipv4      11396  1 
iptable_filter          6528  1 
ip_tables              13840  1 iptable_filter
ip6t_REJECT             7552  2 
nf_conntrack_ipv6      15864  1 
xt_state                5888  2 
nf_conntrack           49748  3 nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
ip6table_filter         6400  1 
ip6_tables             14736  1 ip6table_filter
x_tables               15236  5 ipt_REJECT,ip_tables,ip6t_REJECT,xt_state,ip6_tables
cpufreq_ondemand       10124  1 
acpi_cpufreq           11532  1 
dm_mirror              26116  0 
dm_multipath           18056  0 
dm_mod                 49236  2 dm_mirror,dm_multipath
ipv6                  221660  18 ip6t_REJECT,nf_conntrack_ipv6
snd_hda_intel         330144  3 
snd_seq_dummy           6660  0 
snd_seq_oss            30364  0 
snd_seq_midi_event      9600  1 snd_seq_oss
arc4                    5760  2 
snd_seq                48448  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
ecb                     6528  2 
i915                   84484  2 
snd_seq_device         10124  3 snd_seq_dummy,snd_seq_oss,snd_seq
iTCO_wdt               13476  0 
snd_pcm_oss            42496  0 
snd_mixer_oss          16768  1 snd_pcm_oss
snd_pcm                67076  2 snd_hda_intel,snd_pcm_oss
drm                   145508  3 i915
snd_timer              21640  2 snd_seq,snd_pcm
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
snd_hwdep              10500  1 snd_hda_intel
iTCO_vendor_support     6916  1 iTCO_wdt
crypto_blkcipher       17924  1 ecb
video                  20368  0 
snd                    48312  16
snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
output                  6656  1 video
iwl3945               145244  0 
mac80211              185184  1 iwl3945
joydev                 12608  0 
b44                    25488  0 
ac                      8068  0 
i2c_algo_bit            8964  1 i915
i2c_i801               11920  0 
wmi                     9640  0 
button                 10000  0 
battery                14084  0 
ssb                    34052  1 b44
mii                     8192  1 b44
cfg80211               24712  2 iwl3945,mac80211
i2c_core               20628  4 i915,drm,i2c_algo_bit,i2c_i801
soundcore               9288  1 snd
dcdbas                 10272  0 
sr_mod                 17064  0 
sg                     31028  0 
cdrom                  32796  1 sr_mod
ata_generic             8964  0 
pata_acpi               8192  0 
ata_piix               20100  3 
libata                126688  3 ata_generic,pata_acpi,ata_piix
sd_mod                 25624  4 
scsi_mod              120820  4 sr_mod,sg,libata,sd_mod
ext3                  108424  2 
jbd                    40852  1 ext3
mbcache                10116  1 ext3
uhci_hcd               22928  0 
ohci_hcd               22276  0 
ehci_hcd               32268  0 

Output of /sbin/lspci:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
Comment 1 Bug Zapper 2008-05-14 06:37:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Gwyn Ciesla 2008-05-16 16:15:25 EDT
This one I don't see.  I'm using radeon.
Comment 3 Christopher Tubbs 2008-05-16 16:45:34 EDT
Add'l info: I'm using a Dell E1405 notebook. Intel chipset. The issue occurs
even with A/C power cord plugged in.
Comment 4 Gwyn Ciesla 2008-06-12 09:58:55 EDT
I assume this is fullscreen.  Does it happen if you run it in windowed mode?
Comment 5 Gwyn Ciesla 2008-09-09 15:12:54 EDT
I still can't reproduce this.  Did you try my suggestion in #4?
Comment 6 Gwyn Ciesla 2008-12-31 11:37:53 EST
Ping?
Comment 7 Christopher Tubbs 2009-01-28 23:25:45 EST
Sorry, I haven't been following this bug since the issues with the sound ever since pulseaudio was introduced in Fedora 8 have caused me to cease playing it. Perhaps somebody else can reproduce the bug. Otherwise, it's probably best to close this.
Comment 8 Gwyn Ciesla 2009-01-29 09:19:46 EST
I might be able to if I had the hardware, but I don't.  Are you able to test on whatever version you're running on that laptop now?
Comment 9 Christopher Tubbs 2009-01-30 23:14:45 EST
I have checked this bug against Fedora 10, armacycles-ad-0.2.8.2.1-6.fc9.x86_64 and have not seen it occur. I did, however, see it dim the first time I ran it, but upon exit, not upon startup. This was in fullscreen mode. It has not happened since.

While testing, I did see another bug, regarding screen artifacts, that I will address in a separate bug report.
Comment 10 Gwyn Ciesla 2009-02-02 12:15:50 EST
So you now cannot reproduce it at all?
Comment 11 Christopher Tubbs 2009-02-02 20:02:24 EST
(In reply to comment #10)
> So you now cannot reproduce it at all?

Correct, I cannot reproduce at all in Fedora 10 with armacycles-ad-0.2.8.2.1-6.fc9.x86_64 and kernel-2.6.27.12-170.2.5.fc10.x86_64.
Comment 12 Gwyn Ciesla 2009-02-03 09:30:15 EST
Then, annoyed as I am by this, we'll have to call it resolved.

Note You need to log in before you can comment on or make changes to this bug.