Bug 445141 - Totem Movie Player will not display Ogg video in F9 LiveCD
Totem Movie Player will not display Ogg video in F9 LiveCD
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-04 12:02 EDT by Anthony Thomas
Modified: 2008-05-19 09:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 09:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of Totem playing an Ogg file and the White screen that shows (29.43 KB, image/png)
2008-05-04 12:02 EDT, Anthony Thomas
no flags Details

  None (edit)
Description Anthony Thomas 2008-05-04 12:02:25 EDT
Description of problem: After installing Fedora 9 Preview Release and updating
via Yum to rawhide, Ogg video files do not display video within Totem Movie
Player. Audio is heard, but video just displays a white screen.

I have tried this on two Ogg files so far with the same results. These files
play fine in Fedora 8. 

Version-Release number of selected component (if applicable):
Totem Movie Player 2.23.2
Movie Player using xine-lib version 1.1.12 and GNOME

How reproducible: Install F9 Preview from LiveCD, do a yum update, and play an
Ogg file.


Steps to Reproduce:
1. Install F9 Preview from LiveCD
2. yum update
3. play an Ogg file.
Comment 1 Anthony Thomas 2008-05-04 12:02:25 EDT
Created attachment 304495 [details]
Screen shot of Totem playing an Ogg file and the White screen that shows
Comment 2 Jeremy Katz 2008-05-04 14:45:13 EDT
What graphics chip does your machine have?
Comment 3 Anthony Thomas 2008-05-05 06:23:52 EDT
(In reply to comment #2)
> What graphics chip does your machine have?

Sorry, forgot to mention that I have a laptop (IBM T60) with an ATI Mobility
Raedon x1300. Xorg.conf shows that F9 is using a Raedon driver. As a test, I
told xorg to use VESA, but than X would not start. I than put 'ATI' in the
driver section of xorg and X was able to start, but the video player issue with
OGG files still exists.
Comment 4 Bastien Nocera 2008-05-07 08:20:04 EDT
Are you using compiz or another compositing manager? If so, try without.
Does it work with the GStreamer backend (switch using "totem-backend -b
gstreamer" as root), or xine (in the xine-ui package)?
Comment 5 Anthony Thomas 2008-05-07 09:41:58 EDT
No Compiz or anything like that installed. Just plain Fedora 9 LiveCD installed
with adobe flash.
I'll try the gstreamer backend and report back. Thanks
Comment 6 Anthony Thomas 2008-05-11 22:46:44 EDT
switching to the Gstreaner backend doesn't resolve the issue. I even uninstalled
the xine backend just in case.
I guess I'll wait until Livna releases an ATI driver for F9 in the repo and
install it to see if that fixes the issue.
Comment 7 Bug Zapper 2008-05-14 06:38:00 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Anthony Thomas 2008-05-19 09:38:12 EDT
This has been solved after receiving one of the xorg-x11-drv-ati updates soon 
after the F9 final release. Works like a charm now. ;)
I'm not sure how to close this bug report, so I just changed it 
to 'WORKSFORME'.

Note You need to log in before you can comment on or make changes to this bug.