Bug 445270 - firefox crashes when trying to watch YouTube.com if libflashsupport is installed
firefox crashes when trying to watch YouTube.com if libflashsupport is installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libflashsupport (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 16:59 EDT by Dawid Pietrala
Modified: 2009-07-14 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dawid Pietrala 2008-05-05 16:59:02 EDT
Description of problem:

when trying to watch a few films at YouTube.com, firefox suddenly crashed. when
run from Terminal, at the moment of crash it displays:
/usr/lib/firefox-3.0b5/run-mozilla.sh: line 131:  3132 Segmentation fault     
"$prog" ${1+"$@"}

or

/usr/lib/firefox-3.0b5/run-mozilla.sh: line 131:  7913 Segmentation fault     
"$prog" ${1+"$@"}

the problem disappears when i get rid of libflashsupport.

Version-Release number of selected component (if applicable):

libflashsupport-000-0.5.svn20070904.i386

also:

flash-plugin-9.0.124.0-release.i386
firefox-3.0-0.60.beta5.fc9.i386


How reproducible:

i tested it on 2 different computers: a desktop and a laptop. in case of the
desktop, the problem occured every time i tried to watch any film. on the
laptop, the problem appeared only occassionally.

Steps to Reproduce:

Two ways:
1. open YouTube.com
2. choose any film appearing on the homepage (sometimes you have to open a few
before it crashes)
3. watch your wallpaper

and:

1. open YouTube.com
2. choose any film, then jump to another, then to another, and go back. it will
freeze and then crash.
  
Actual results:

Firefox crashes annoyingly.

Expected results:

Every film should be played smoothly.


Additional info:
Comment 1 Dawid Pietrala 2008-05-08 18:50:44 EDT
today i've noticed that sometimes (again the difference between the desktop and
the laptop), when trying to watch a film in YouTube.com, sound turns into
horrible noise which can't be turned down. the only remedy to my ears is to exit
firefox.

please, take care of that as these bugs are really distracting. if you need any
more info, just let me know. 
Comment 2 Viktor Erdelyi 2008-05-12 05:33:43 EDT
For me, flash has NO sound at all and even crashes sometimes when
libflashsupport is NOT installed (especially at myspace music). I installed
libflashsupport, now it sends everything to pulseaudio, and works. I admit that
it's strange when compared to your experience :)

(I'm using Fedora 9 and Firefox 3b5)
Comment 3 Viktor Erdelyi 2008-05-12 05:35:02 EDT
Maybe useful (it's for ubuntu but that's how I solved it):
http://markusthielmann.com/blog/defusing_one_most_annoying_bugs_ubuntu_hardy_heron_stop_flash_killing_firefox
Comment 4 Bug Zapper 2008-05-14 06:40:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Rayad Barakat 2008-05-25 01:13:15 EDT
Hi guys,

I'm totally new to this. In fact, this last week was the first time that I sat
down and actually worked with a Linux distro, so bear with me if what I say or
suggest makes no sense at all -- I'm essentially blind, and if what I've done
works then it was just dumb luck and a bit of research.

I did this on a persistent live usb install where I was having frequent crashes
proceeded by massive cpu usage whenever flash content would show up on a page.
These crashes would render the USB drive unusable, and I would have to reinstall
the live image.

Either way, after some investigation I found that the npviewer.bin process was
spiking cpu usage, and began terminating it and reloading the page whenever I
would have to deal with flash content. Needless to say, this is hardly a fix.

Reading the suggestions for Ubuntu didn't really help me as I'm not familiar
enough with the system to adapt the instructions.

While reading bug reports I found one user complaining about config changes not
being saved across updates of nspluginwrapper. Curious, I navigated to the file
and opened it (took me a couple tried to figure out how to do it as root). I
noticed a line listing things that are excluded by the plug-in, among them
gecko-mediaplayer and totem. Figuring that since none of these have given me
problems yet, I added libflashsupport to the exclusions.

Keep in mind I only did this about an hour ago, but going through a few youtube
videos, although resulting in higher cpu usage as usual(same amount as when
libflashsupport was not installed, less than when it was installed and not
excluded), did not bring the system to its knees.

I suspect that the cpu usage is simply from running the flash plugin and that
the addition of libflashsupport might be pushing it over the edge.

Then again, I'm a complete newbie, and I will now post in case I get another crash.

Feel free to delete this if it's all BS, I won't mind, especially if I get
another crash.
Comment 6 Bug Zapper 2009-06-09 20:37:51 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-07-14 12:41:31 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.