Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 445290 - traceback with UnicodeDecodeError
traceback with UnicodeDecodeError
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-05 19:42 EDT by Lee Dae Jong
Modified: 2008-05-28 15:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:45:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report file (3.12 KB, application/octet-stream)
2008-05-05 19:42 EDT, Lee Dae Jong
no flags Details

  None (edit)
Description Lee Dae Jong 2008-05-05 19:42:10 EDT
Description of problem:
software update is failed

How reproducible:
I use gnome gui. I selected program->system->software update and then problem
occured as below

>>>>>>>>>>>>>>>>>>>>>>>>>>
Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 287, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 369, in populateUpdates
    % (rpmUtils.miscutils.splitFilename(srpm)[0],),
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 3-4: invalid data

Local variables in innermost frame:
opt: True
repo: updates
updated: taglib - 1.4-5.fc7.i386
old: (u'taglib', 'i386', '0', '1.4', '5.fc7')
repos: ['updates']
upds: {u'evolution-2.10.3-9.fc7.src.rpm': [(<bound method
PackageUpdater._doUpdate of <__main__.PackageUpdater object at 0x8bf30cc>>,
<bound method PackageUpdater._printUpdate of <__main__.PackageUpdater object at
0x8bf30cc>>, <yum.sqlitesack.YumAvailablePackageSqlite object at 0xa94a78c>,
<yum.packages.YumInstalledPackage object at 0xaa7ad0c>)],
u'speex-1.2-0.3.beta1.src.rpm': [(<bound method PackageUpdater._doUpdate of
<__main__.PackageUpdater object at 0x8bf30cc>>, <bound method
PackageUpdater._printUpdate of <__main__.PackageUpdater object at 0x8bf30cc>>,
<yum.sqlitesack.YumAvailablePackageSqlite object at 0xe98548c>,
<yum.packages.YumInstalledPackage object at 0xe9851ec>)],
u'rsync-2.6.9-6.fc7.src.rpm': [(<bound method PackageUpdater._doUpdate of
<__main__.PackageUpdater object at 0x8bf30cc>>, <bound method
PackageUpdater._printUpdate of <__main__.PackageUpdater object at 0x8bf30cc>>,
<yum.sqlitesack.YumAvailablePackageSqlite object at 0xe985d2c>,
<yum.packages.YumInstalledPackage object at 0xa7fd2cc>)],
u'taglib-1.5-1.fc7.src.rpm': [(<bound method PackageUpdater._doUpdate of
<__main__.PackageUpdater object at 0x8bf30cc>>, <bound method
PackageUpdater._printUpdate of <__main__.PackageUpdater object at 0x8bf30cc>>,
<yum.sqlitesack.YumAvailablePackageSqlite object at 0xe97fc0c>,
<yum.packages.YumInstalledPackage object at 0xe97f74c>)]}
reboots: {u'evolution-2.10.3-9.fc7.src.rpm': False,
u'speex-1.2-0.3.beta1.src.rpm': False, u'rsync-2.6.9-6.fc7.src.rpm': False,
u'taglib-1.5-1.fc7.src.rpm': False}
pix: None
lst: [(<bound method PackageUpdater._doUpdate of <__main__.PackageUpdater object
at 0x8bf30cc>>, <bound method PackageUpdater._printUpdate of
<__main__.PackageUpdater object at 0x8bf30cc>>,
<yum.sqlitesack.YumAvailablePackageSqlite object at 0xa94a78c>,
<yum.packages.YumInstalledPackage object at 0xaa7ad0c>)]
updates: [((u'evolution', u'i386', u'0', u'2.10.3', u'9.fc7'), (u'evolution',
'i386', '0', '2.10.3', '8.fc7')), ((u'rsync', u'i386', u'0', u'2.6.9',
u'6.fc7'), (u'rsync', 'i386', '0', '2.6.9', '3.fc7')), ((u'speex', u'i386',
u'0', u'1.2', u'0.3.beta1'), (u'speex', 'i386', '0', '1.2', '0.2.beta1')),
((u'taglib', u'i386', u'0', u'1.5', u'1.fc7'), (u'taglib', 'i386', '0', '1.4',
'5.fc7'))]
new: (u'taglib', u'i386', u'0', u'1.5', u'1.fc7')
srpm: evolution-2.10.3-9.fc7.src.rpm
self: <__main__.PackageUpdater object at 0x8bf30cc>
updating: taglib - 1.5-1.fc7.i386
obsoletes: []
Comment 1 Lee Dae Jong 2008-05-05 19:42:10 EDT
Created attachment 304576 [details]
bug report file
Comment 2 Bug Zapper 2008-05-14 11:28:45 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jeremy Katz 2008-05-28 15:45:59 EDT
This should be fixed with the version currently available in the updates repo

Note You need to log in before you can comment on or make changes to this bug.