Bug 445351 - Bluetooth no longer works in GNOME
Bluetooth no longer works in GNOME
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 08:36 EDT by Karl Lattimer
Modified: 2008-05-06 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 10:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Lattimer 2008-05-06 08:36:00 EDT
Description of problem:

When selecting display icon only when adapter present no longer shows the
bluetooth icon on a macbook 13 core due (not core 2 duo), this problem has
persisted since an upgrade to fedora 8 through to rawhide.
Comment 1 Bastien Nocera 2008-05-06 08:47:15 EDT
What's the output of hciconfig on your machine? What's the output of:
gconftool-2 --get /apps/bluetooth-manager/icon_policy
?
Comment 2 Karl Lattimer 2008-05-06 09:52:57 EDT
hciconfig outputs nothing

[karl@localhost applications]$ gconftool-2 --get /apps/bluetooth-manager/icon_policy
present

lsmod shows the modules still loaded 

rfcomm                 34576  0 
l2cap                  22272  3 rfcomm
bluetooth              47588  2 rfcomm,l2cap

I don't understand why this has become an issue in recent releases. Possibly
something changed in the kernel?
Comment 3 Bastien Nocera 2008-05-06 10:14:50 EDT
Uncomment the line:
HID2HCI_ENABLE=true
in /etc/sysconfig/bluetooth

I believe this was mentioned in the release notes, and necessary to avoid
desktop mac, and other desktops (such as the ones using logitech combos) from
losing their keyboard on bootup.

See the discussion here:
http://thread.gmane.org/gmane.linux.bluez.devel/12584/focus=12601

If we had full specs, we'd be able to support those devices out-of-the-box...
Comment 4 Karl Lattimer 2008-05-06 12:48:31 EDT
Yep that fixed it. Thanks Bastien I owe you a pint at guadec this year :) Stick
it on the beer list. :)

Note You need to log in before you can comment on or make changes to this bug.