This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 445399 - require 'rdoc/usage'' raises an Exception because of a missing require in /usr/lib/ruby/1.8/rdoc/ri/ri_options.rb
require 'rdoc/usage'' raises an Exception because of a missing require in /us...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ruby (Show other bugs)
5.1
All Linux
medium Severity low
: rc
: ---
Assigned To: Vít Ondruch
QE Internationalization Bugs
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 14:12 EDT by Stephen John Smoogen
Modified: 2012-02-21 01:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:00:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2008-05-06 14:12:36 EDT
Description of problem:

ruby raises an exception because of missing requires

require 'rdoc/ri/ri_paths'

upstream bug number: 
http://rubyforge.org/tracker/?func=detail&atid=1698&aid=5563&group_id=426

reported downstream number:
http://bugs.centos.org/view.php?id=2824

ruby-1.8.5-5.el5_1.1

confirmed on CentOS-5.1
tested and confirmed with RHEL-5.2 beta 


0002824: `require 'rdoc/usage'' raises an Exception because of a missing require
in /usr/lib/ruby/1.8/rdoc/ri/ri_options.rb 


How reproducible:
100%
Comment 1 Michael Stahnke 2009-08-24 20:12:04 EDT
Please fix this.  It is affecting production systems.
Comment 2 Michael Stahnke 2009-08-24 20:12:35 EDT
Also, it's still there in 5.3. Patch has been rolled into upstream.
Comment 3 RHEL Product and Program Management 2009-11-06 14:11:57 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 errata-xmlrpc 2012-02-21 01:00:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0218.html

Note You need to log in before you can comment on or make changes to this bug.