Bug 445481 - Bookmark editor looses contents of folders.
Bookmark editor looses contents of folders.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 23:58 EDT by charles harris
Modified: 2008-05-08 10:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-08 10:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 432814 None None None Never

  None (edit)
Description charles harris 2008-05-06 23:58:23 EDT
Description of problem:
Cut and paste of a folder looses contents of subfolders.

Version-Release number of selected component (if applicable):
Firefox 3 Beta 5

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-05-07 15:10:17 EDT
Cannot reproduce with firefox-3.0-0.60.beta5.fc9.i386
Comment 2 Matěj Cepl 2008-05-07 15:13:19 EDT
Can you reproduce the problem with the upstream binary from
http://www.mozilla.com/en-US/firefox/all-beta.html
Comment 3 charles harris 2008-05-07 15:27:58 EDT
That's the same version I'm using. Maybe it is dependent on the details:

1) I import bookmarks from an old bookmarks.html.
2) This doesn't put my own toolbar folders where they need to be.
3) Delete all of the default Bookmark Toolbar folders except Smart Bookmarks.
4) Cut/copy my old personal toolbar folders and paste into Bookmarks Toolbar.
5) Subfolders are empty but all the higher level content is there.

So maybe it is something special to the Bookmarks Toolbar?

I'll give the upstream binary a shot and get back to you.
Comment 4 charles harris 2008-05-07 15:42:36 EDT
So, how do I install the upstream version? Zarro instructions at the website,
circular reference in the README, no make, no nuttin', and the libraries don't
look like they all go in one spot. Very unimpressive.
Comment 5 charles harris 2008-05-07 15:51:21 EDT
I was going to try cut/paste to a different folder, but I wasn't able to create
one in the bookmarks editor. What's up with that?
Comment 6 Matěj Cepl 2008-05-07 18:45:25 EDT
(In reply to comment #4)
> So, how do I install the upstream version? Zarro instructions at the website,
> circular reference in the README, no make, no nuttin', and the libraries don't
> look like they all go in one spot. Very unimpressive.

Just unpack tarball, cd into it, and run
./firefox
Comment 7 charles harris 2008-05-08 00:05:19 EDT
Still fails. And I still can't create a folder in the top level.
Comment 8 Matěj Cepl 2008-05-08 10:16:59 EDT
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=432814) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.