Bug 445496 - Feature request for piranha
Summary: Feature request for piranha
Status: CLOSED DUPLICATE of bug 250888
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: piranha (Show other bugs)
(Show other bugs)
Version: 5.4
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-07 07:28 UTC by Eugenij Shkrigunov
Modified: 2009-04-16 22:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 13:24:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eugenij Shkrigunov 2008-05-07 07:28:01 UTC
Utility ipvsadm has options for change the timeout values used for IPVS 
connections "--set tcp tcpfin udp". pulse/lvs.cf does not have such options.
Please add such options. Thank you.

Comment 1 Eugenij Shkrigunov 2008-09-10 05:47:46 UTC
Workaround:

echo SET_TIMEOUT=\"604800 0 0\" > /etc/sysconfig/ipvsadm

pulse.diff
--- /etc/rc.d/init.d/pulse.orig 2007-01-15 09:40:01.000000000 +0300
+++ /etc/rc.d/init.d/pulse      2008-05-07 11:05:12.000000000 +0400
@@ -24,6 +24,8 @@

 [ -f /etc/sysconfig/ha/lvs.cf ] || exit 0

+[ -f /etc/sysconfig/ipvsadm ] && . /etc/sysconfig/ipvsadm
+
 RETVAL=0

 # See how we were called.
@@ -33,7 +35,10 @@
         daemon pulse
        RETVAL=$?
         echo
-        [ $RETVAL -eq 0 ] && touch /var/lock/subsys/pulse
+        [ $RETVAL -eq 0 ] && {
+           touch /var/lock/subsys/pulse
+           [ -n "$SET_TIMEOUT" ] && ipvsadm --set $SET_TIMEOUT
+       }
         ;;

   stop)

Comment 2 Eugenij Shkrigunov 2008-09-26 05:29:05 UTC
Sorry, /etc/sysconfig/ipvsadm is used for storing ipvsadm rules.

echo SET_TIMEOUT=\"604800 0 0\" > /etc/sysconfig/pulse

--- pulse.orig  2007-01-15 09:40:01.000000000 +0300
+++ pulse       2008-09-26 09:25:23.000000000 +0400
@@ -24,6 +24,8 @@

 [ -f /etc/sysconfig/ha/lvs.cf ] || exit 0

+[ -f /etc/sysconfig/pulse ] && . /etc/sysconfig/pulse
+
 RETVAL=0

 # See how we were called.
@@ -33,7 +35,10 @@
         daemon pulse
        RETVAL=$?
         echo
-        [ $RETVAL -eq 0 ] && touch /var/lock/subsys/pulse
+        [ $RETVAL -eq 0 ] && {
+           touch /var/lock/subsys/pulse
+           [ -n "$SET_TIMEOUT" ] && ipvsadm --set $SET_TIMEOUT
+       }
         ;;

   stop)

Comment 3 Marek Grac 2009-01-08 13:24:19 UTC
This feature will be in RHEL 5.3

*** This bug has been marked as a duplicate of bug 250888 ***


Note You need to log in before you can comment on or make changes to this bug.