Bug 445546 - complex widcards fail to match file names
complex widcards fail to match file names
Status: CLOSED DUPLICATE of bug 479774
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vsftpd (Show other bugs)
4.6
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Skala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 10:55 EDT by Dan Holstad
Modified: 2014-11-09 17:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 07:08:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Holstad 2008-05-07 10:55:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
Directory listings with multiple wildcards returns no matches when valid matches are present.

ftp> dir 20080401*.txt
227 Entering Passive Mode (66,196,128,13,146,195)
150 Here comes the directory listing.
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1234_TST_1234.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1235_TST_1235.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1236_TST_1236.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1237_TST_1237.txt
226 Directory send OK.
ftp> dir 20080401_*_*_*.txt
227 Entering Passive Mode (66,196,128,13,168,10)
150 Here comes the directory listing.
226 Directory send OK.
ftp> bye




Version-Release number of selected component (if applicable):
vsftpd-2.0.1-5.EL4.7

How reproducible:
Always


Steps to Reproduce:
1.create files with multiple underscores in the name
$ touch 20080401_1234_TST_1234.txt
$ touch 20080401_1235_TST_1235.txt
$ touch 20080401_1236_TST_1236.txt
$ touch 20080401_1237_TST_1237.txt
2. ftp to server and do a directory listing

3.

Actual Results:
ftp> dir 20080401*.txt
227 Entering Passive Mode (66,196,128,13,146,195)
150 Here comes the directory listing.
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1234_TST_1234.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1235_TST_1235.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1236_TST_1236.txt
-rw-rw-r--    1 518      519             0 May 07 14:45 20080401_1237_TST_1237.txt
226 Directory send OK.
ftp> dir 20080401_*_*_*.txt
227 Entering Passive Mode (66,196,128,13,168,10)
150 Here comes the directory listing.
226 Directory send OK.
ftp> bye


Expected Results:
directory listings with multiple wildcards should return all matching file names

Additional info:
Comment 1 Daniel McNamara 2008-05-14 22:45:28 EDT
Managed to replicate this on the clients behalf on both RHEL 4 and RHEL 5 vsftpd
installs.

Curiously the use of two wildcards in the listing works fine. Only upon the
third wildcard does vsftpd start returning empty results sets.

Not sure if this is an intended limitation of vsftpd or an actual bug.
Comment 4 Dan Holstad 2008-05-15 15:56:01 EDT
This was working in the prior release. It seems to have started when the *1 fix
was implemented.
Comment 8 RHEL Product and Program Management 2008-10-31 12:37:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 Jiri Skala 2009-01-19 07:08:35 EST

*** This bug has been marked as a duplicate of bug 479774 ***

Note You need to log in before you can comment on or make changes to this bug.