Bug 445606 - multiple rshd bugs: arg_max, audit, pam_rhosts
multiple rshd bugs: arg_max, audit, pam_rhosts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rsh (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 18:32 EDT by Gilbert E. Detillieux
Modified: 2013-04-30 19:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.17-50.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 11:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix arg_max and audit bugs (1.00 KB, patch)
2008-05-07 18:32 EDT, Gilbert E. Detillieux
no flags Details | Diff

  None (edit)
Description Gilbert E. Detillieux 2008-05-07 18:32:11 EDT
Description of problem:
Recent patches to rsh package introduced 2 new bugs: one due to a missed line in
the arg_max patch, one due to incorrect return code checks in the audit patch.
Also, recent pam versions changed name of pam_rhosts_auth.so module to
pam_rhosts.so.

Version-Release number of selected component (if applicable):
0.17-49.fc9

How reproducible:
fails consistently

Steps to Reproduce:
1. try running "rsh localhost w" (or similar short command)
2. try running "rsh localhost some_long_command"
3. check log entries in /var/log/messages
(This is after taking all necessary steps to enable rsh service, allow "rsh" in
/etc/securetty, setting up .rhosts, etc.)
  
Actual results:
Commands fail due to missing pam_rhosts_auth.so module specified in
/etc/pam.d/rsh (and rlogin too).  After fixing that, short commands fail with
bogus message "Error sending audit event."  Long commands fail with message
"command too long".

Expected results:
Commands should work.

Additional info:
See attached patch to fix 2 code bugs.  (Change in pam module name is a trivial
edit of rsh.pam and rlogin.pam source files, and is not included.)
Comment 1 Gilbert E. Detillieux 2008-05-07 18:32:11 EDT
Created attachment 304812 [details]
fix arg_max and audit bugs
Comment 2 Adam Tkac 2008-05-09 07:02:38 EDT
Thanks for your report, all problems are fixed in latest build
(rsh-server-0.17-50.fc9). I'm not sure if it will be part of F9 GA or it will be
released as F9 update. I'm going to let you know.
Comment 3 Fedora Update System 2008-05-09 13:28:57 EDT
rsh-0.17-50.fc9 has been submitted as an update for Fedora 9
Comment 4 Adam Tkac 2008-05-12 07:55:24 EDT
It's too late for F9, fixes will be available after F9 release.
Comment 5 Fedora Update System 2008-05-13 11:30:47 EDT
rsh-0.17-50.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.