This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 445640 - Jumping "music" for overload using yum/packagekit
Jumping "music" for overload using yum/packagekit
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 04:22 EDT by Carlo Raudino
Modified: 2008-10-14 08:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 08:55:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
top screen (195.62 KB, image/jpeg)
2008-05-08 08:07 EDT, Carlo Raudino
no flags Details

  None (edit)
Description Carlo Raudino 2008-05-08 04:22:02 EDT
Description of problem: Listening to music with rhythmbox and
updating/refreshing with packagekit or yumex results in "audio jumps"... like
processor overload...looking at cpu load, it seems all workload is in one core..
usually it swapped.
It is strange because I HAVE AN ATHLON X2 @ 3 GHZ !!!

It never happened with fedora 8....
Comment 1 Carlo Raudino 2008-05-08 05:09:23 EDT
It happens with folding@home working in background.

With fedora 8, no problems with folding.

Comment 2 Neil Horman 2008-05-08 06:55:50 EDT
output of /proc/interrupts and /proc/cpuinfo?  If fact an entire sysreport would
be usefull.
Comment 3 Carlo Raudino 2008-05-08 07:07:30 EDT
[root@karlpc ~]# cat /proc/interrupts
           CPU0       CPU1       
  0:       1272   44340004   IO-APIC-edge      timer
  1:      22866         87   IO-APIC-edge      i8042
  4:          0          2   IO-APIC-edge    
  6:          0          5   IO-APIC-edge      floppy
  7:          1          0   IO-APIC-edge      parport0
  8:          0          1   IO-APIC-edge      rtc0
  9:          0          0   IO-APIC-fasteoi   acpi
 14:          0          0   IO-APIC-edge      pata_amd
 15:     462714       2488   IO-APIC-edge      pata_amd
 17:     326174       4895   IO-APIC-fasteoi   CMI8738-MC6
 18:        672         22   IO-APIC-fasteoi   firewire_ohci
 19:     191334        623   IO-APIC-fasteoi   bttv0, radeon@pci:0000:01:00.0
 20:          0          0   IO-APIC-fasteoi   ohci_hcd:usb3
 21:    4707176      29051   IO-APIC-fasteoi   ohci_hcd:usb2, eth0
 22:    1220424       3525   IO-APIC-fasteoi   ehci_hcd:usb1, sata_nv
NMI:          0          0   Non-maskable interrupts
LOC:   44339994       1109   Local timer interrupts
RES:     463725     754955   Rescheduling interrupts
CAL:       6342        116   function call interrupts
TLB:       6329       6801   TLB shootdowns
TRM:          0          0   Thermal event interrupts
SPU:          0          0   Spurious interrupts
ERR:          1
MIS:          0

-------------------------------------------------------------

[root@karlpc ~]# cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow
pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch ts fid vid ttp
tm stc 100mhzsteps
bogomips	: 2300.30
clflush size	: 64

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow
pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch ts fid vid ttp
tm stc 100mhzsteps
bogomips	: 2300.30
clflush size	: 64



Comment 4 Neil Horman 2008-05-08 07:33:14 EDT
This isn't an irqbalance problem.  Looking at /proc/interrupts, its clear that
irqbalance is isolating the all the high volume interrupt sources to one cpu or
the other, which is working as expected.  Something is waking up cpu0 a good
deal though as is evidenced by the excessive number of local timer interrupts. 
What does top show when you see these audio jumps?
Comment 5 Carlo Raudino 2008-05-08 08:07:03 EDT
Created attachment 304851 [details]
top screen

That's a screen of my top while some jumps..

Looking at top, I found it happens with python applications...

Rhythmbox is also a python app, no ?

I have "jumps" while listening music with: packagekit and yumex... maybe I can
try with other applications...
Comment 6 Neil Horman 2008-05-08 08:26:02 EDT
Nope, rhythmbox is written in C/C++ and doesn't show up on your top list.

search-group.py is part of packagekit, and seems to be where the majority of
your cpu utilitzation comes from.  Why I couldn't tell you why, but clearly its
eating up your cpu time.

Folding at home is also a big user of the cpu.  I have no idea what on earth its
doing, you would have to take up the matter with them.

Reassigning to packagekit for further investigation.
Comment 7 Bug Zapper 2008-05-14 06:49:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Richard Hughes 2008-10-14 08:55:04 EDT
I've reniced the daemon in rawhide. Other than that, I don't think this is a Pk bug at all.

Note You need to log in before you can comment on or make changes to this bug.