Bug 445676 - iostat reports %util greater than 100%
iostat reports %util greater than 100%
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysstat (Show other bugs)
4.5
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Ivana Varekova
Brian Brock
:
: 590148 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 10:00 EDT by Keith Kearnan
Modified: 2010-10-22 20:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 08:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Kearnan 2008-05-08 10:00:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060527 SUSE/1.5.0.4-1.9 Firefox/1.5.0.4

Description of problem:
When using iostat to monitor performance the %util is seen to go above 100%.  The device being monitored is a MegaRAID Logical Volume.

Version-Release number of selected component (if applicable):
sysstat-5.0.5-14.rhel4

How reproducible:
Always


Steps to Reproduce:
1. Install an I/O generating package, I used iozone.
2. Launch the I/O generator (./iozone -Ra -s 1G -r 1024 -g 4G -f /home/all1.tmp).
3. Monitor I/O with iostat (iostat -x 1 10 | grep "sda ")

Actual Results:
[root@l82bi036 ~]# iostat -x 1 10 | grep "sda "
Device:    rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s    rkB/s    wkB/s avgrq-sz avgqu-sz   await  svctm  %util
sda          0.05  29.16  0.49  2.59   18.89  254.06     9.44   127.03    88.49     0.89  288.12   0.49   0.15
sda          0.00 125010.89  0.00 2246.53    0.00 1066835.64     0.00 533417.82   474.88  2782.59  195.56   0.44  99.11
sda          0.00   0.00  0.00 2260.00    0.00    0.00     0.00     0.00     0.00  5134.15  993.58   0.44 100.10
sda          0.00   0.00  0.00 2273.00    0.00    0.00     0.00     0.00     0.00  2881.88 1870.48   0.44 100.10
sda          0.00 262.00  0.00 1753.00    0.00 2296.00     0.00  1148.00     1.31   674.11 2602.56   0.46  80.70
sda          0.00 29759.00  0.00 1942.00    0.00 254464.00     0.00 127232.00   131.03    56.42   27.66   0.28  55.10
sda          0.00 35303.00  0.00 2397.00    0.00 301640.00     0.00 150820.00   125.84   108.12   45.27   0.42 100.10
sda          0.00 99921.00  0.00 2271.00    0.00 852704.00     0.00 426352.00   375.48   976.82   98.13   0.44 100.20
sda          0.00 80701.00  0.00 2089.00    0.00 688672.00     0.00 344336.00   329.67  7576.35  763.71   0.48 100.10
sda          0.00   0.00  0.00 2250.00    0.00    0.00     0.00     0.00     0.00  6681.62 1597.33   0.44 100.10


Expected Results:
The maximum value for %util should be 100%.

Additional info:

Server: Dell 6650 with 6 disk internal MegaRAID volume.
OS: RHEL4.5 (2.6.9-55.0.12.ELsmp)
# df -kh
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      165G   12G  145G   8% /
/dev/sda1              99M   17M   78M  18% /boot

EMC PowerPath is NOT installed on this server.
Comment 1 Ivana Varekova 2008-05-15 08:49:48 EDT
This problem appears because of in iostat command between the actions "reads
data which are used to count the delay" and "read data which are used to count
utilization" could be a small time delay which caused this inaccuracy. There is
no way how to fix this problem, I discuss this with upstream maintainer and he
prefers to leave tis problem as it is. Closing -> wontfix.
Comment 3 Ivana Varekova 2010-06-28 05:44:07 EDT
*** Bug 590148 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.