Bug 445704 - stage2.img not found when boot.iso is converted to vfat pendrive
stage2.img not found when boot.iso is converted to vfat pendrive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-08 12:30 EDT by Noa Resare
Modified: 2008-09-30 12:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 12:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2008-05-08 12:30:28 EDT
Description of problem:
I don't like to burn iso images for each and every fedora release and pre-release I test, when I have a 
coputer that is kind enough to boot from an USB stick.

Version-Release number of selected component (if applicable):
The anaconda that lives on boot.iso that is a part of Fedora 9-Preview

How reproducible:
Always

Steps to Reproduce:
1. loopback mount boot.iso and copy the contents to your pendrive, rename the isolinux dir to syslinux 
and isolinux.cfg to syslinux.cfg. Run the syslinux command to make your pendrive bootable.
2. boot from your newly created boot device
3. be forced to download stage2.img over the net, even though it is on the drive in the images dir
  
Actual results:
Anaconda does not detect the availability of a stage2.img on a pendrive created from a boot.iso file

Expected results:
Seamless boot into graphical mode, or at least the ability to select the correct hard drive and have 
anaconda use stage2.img from there

Additional info:
If i elect to get stage2.img from a hard drive and select my pendrive device it seems to mount correctly,  
because if I enter the correct device but a nonexistent directory I will get another error than the one I 
get entering / or /images
Comment 1 Andy Lindeberg 2008-06-03 12:05:12 EDT
Have you tried this with the final release of F9?
Comment 2 Noa Resare 2008-06-09 04:42:32 EDT
This issue still exists with the final F9 release. I have tested

feff66dde8ca568c23852d6dcd971c95264b7cb4  Fedora-9-x86_64-netinst.iso

and it has the issue described above. 
Comment 3 Chris Lumens 2008-07-24 09:52:17 EDT
I've completely changed around the stage2 finding code, so it's worth trying
again with rawhide and seeing what the status is there.

Note You need to log in before you can comment on or make changes to this bug.