Bug 445714 - konqueror: Cannot copy and paste in a single window
konqueror: Cannot copy and paste in a single window
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-08 14:15 EDT by Michael Best
Modified: 2008-05-09 13:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-09 13:28:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 155080 None None None Never

  None (edit)
Description Michael Best 2008-05-08 14:15:42 EDT
Description of problem:
Copying a file in konqueror and then changing directory, it is not possible to
paste that file.  Copying and pasting between a split view or two windows still

Apparently fixed in a later revision.

Version-Release number of selected component (if applicable):

Comment 1 Kevin Kofler 2008-05-08 14:29:16 EDT
That bug report specifies a huge range of revisions and the fix is somewhere in 
it. I'm trying to identify the exact commit which fixed it.

Is a file selected when you try to paste? If so, it's probably this: 
That fix appears not to have been backported to 4.0. :-( Make sure you don't 
select a file when pasting and it will work.
Comment 2 Michael Best 2008-05-08 15:08:27 EDT
Is that version of the code in the current codebase?

If not, then this is not the behaviour of the bug I am experiencing.  I have
tried not selecting anything in the destination, it makes no difference for me.

Open a Konqueror window, select a file, either use a menu to select copy or hit

Control-V doesn't work in that same window.

If I change to a different directory.  On the menus, the text of the action is
correct (1 file, 2 files, etc) but they action is greyed out.

If I have a separate Konqueror window open I can switch focus to that window and
Control-V works, and appears in the context menus.

791354 appears to be a good candidate:

Comment 3 Kevin Kofler 2008-05-08 15:16:08 EDT
Revision 791354 is the fix for kde#159862, which you say is not the issue 
you're encountering, so no, that's not it.
Comment 4 Michael Best 2008-05-08 15:31:20 EDT
I thought I saw something to do with i8ln problems causing this somehow.

Here is another bug you can look at with similar problems:
Comment 5 Michael Best 2008-05-08 15:32:47 EDT
That bug is not useful in this case.
Comment 6 Rex Dieter 2008-05-08 15:41:32 EDT
Confirmed works fine (for me) on kde-4.0.4
Comment 7 Rex Dieter 2008-05-08 15:42:18 EDT
doh, nevermind, works in dolphin, *not* in konq.
Comment 8 Michael Best 2008-05-08 15:50:11 EDT
Just tried the deselection in dolphin, that seems to work fine.  I think I'll
just switch to dolphin for now.
Comment 9 Kevin Kofler 2008-05-08 16:17:14 EDT
Maybe this was our mystery fix?
(This hasn't been backported to 4.0.)
Comment 10 Kevin Kofler 2008-05-08 16:18:20 EDT
I'm not convinced it has anything to do with this bug though.
Comment 11 Rex Dieter 2008-05-09 11:27:54 EDT
I'm of a mind to punt this closed->upstream , and wait for kde-4.1. (or
kde-4.0.5 if it happens to get fixed there).  
Comment 12 Michael Best 2008-05-09 13:20:51 EDT
Doesn't bother me, just brought it up to raise awareness of the issue.
Comment 13 Rex Dieter 2008-05-09 13:28:22 EDT
fair nuf (thx for the report, as always).

Note You need to log in before you can comment on or make changes to this bug.