Bug 445789 - Unable to create a PV guest with > 3 disks
Unable to create a PV guest with > 3 disks
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression, ZStream
Depends On: 445476
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-09 03:11 EDT by RHEL Product and Program Management
Modified: 2009-12-14 15:59 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0279
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2008-05-09 03:11:17 EDT
This bug has been copied from bug #445476 and has been proposed
to be backported to 5.2 z-stream (EUS).
Comment 3 RHEL Product and Program Management 2008-05-09 03:25:19 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 Martin Jenner 2008-05-17 06:20:11 EDT
verified:

- dom0 installed rpms

# rpm -q xen xen-libs
xen-3.0.3-64.el5_2.1
xen-libs-3.0.3-64.el5_2.1

- from dom0 guest config file, attached disks where 40 MB each

disk = [ "tap:aio:/var/lib/xen/images/rhel5tree_i386.img,xvda,w",
"tap:aio:/var/lib/xen/images/file1.1,xvdb,w",
"tap:aio:/var/lib/xen/images/file1.2,xvdc,w","tap:aio:/var/lib/xen/images/file1.3,xvdd,w",
"tap:aio:/var/lib/xen/images/file1.4,xvde,w",
"tap:aio:/var/lib/xen/images/file1.5,xvdf,w",
"tap:aio:/var/lib/xen/images/file1.6,xvdg,w","tap:aio:/var/lib/xen/images/file1.7,xvdh,w"
]

- in booted guest

# cat /proc/partitions 
major minor  #blocks  name

 202     0   10485760 xvda
 202     1     104391 xvda1
 202     2   10377990 xvda2
 202    16       4096 xvdb
 202    32       4096 xvdc
 202    48       4096 xvdd
 202    64       4096 xvde
 202    80       4096 xvdf
 202    96       4096 xvdg
 202   112       4096 xvdh
 253     0    9273344 dm-0
 253     1    1081344 dm-1

- created file system on at least one device and copied files to mounted
partition, confirmed you could delete copied files

# df -h /dev/xvdh1
Filesystem            Size  Used Avail Use% Mounted on
/dev/xvdh1             38M  6.6M   30M  19% /mnt/xx
Comment 9 errata-xmlrpc 2008-05-21 11:31:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0279.html

Note You need to log in before you can comment on or make changes to this bug.