Bug 44582 - more rights for /sbin/ifup-pre-local
more rights for /sbin/ifup-pre-local
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-14 10:40 EDT by Enrico Scholz
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 15:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-06-14 10:40:50 EDT
Description of Problem:

My laptop is operating in a lot of environments where the net can be
configured via DHCP. That's why I am using eth0 (an onboard NIC) with
BOOTPROTO="dhcp".

Sometimes it happens that I am on travel and net is not available. Then
bootprocess is waiting a long time at 'Bringing up interface eth0' before
dhcpcd times out.

Similar conditions are caused by apmd which calls 'ifdown/ifup eth0' at
resume/standby.


/sbin/ifup provides a hook into /sbin/ifup-pre-local

| if [ -x /sbin/ifup-pre-local ]; then
|    /sbin/ifup-pre-local ${DEVICE}
| fi

where I can start tools like mii-tool from net-tools to determine the
link-status. Nevertheless I can not profite from this information because
/sbin/ifup will continue and call `dhcpcd'.

A solution could be if the hook is called as

| if [ -x /sbin/ifup-pre-local ]; then
|   /sbin/ifup-pre-local ${DEVICE} || exit 1
| fi

or

| if [ -x /sbin/ifup-pre-local ]; then
|   source /sbin/ifup-pre-local ${DEVICE}
| fi

Then ifup-pre-local could `return 1' or call `exit 1' if an error (not
linked NIC) occured.
Comment 1 Bill Nottingham 2001-06-17 22:11:10 EDT
This sort of thing is in the current development initscripts; should be in 5.89
or so.
Comment 2 Enrico Scholz 2002-04-11 12:37:50 EDT
Since named functionality was removed in recent initscripts, the issue revives...
Comment 3 Bill Nottingham 2005-04-28 15:13:55 EDT
Currently, we support link checking, so the underlying issue here is resolved.

Note You need to log in before you can comment on or make changes to this bug.