Bug 445913 - unicode codepoints "U+E844" and "U+E863" not represented in Chinese font packages
unicode codepoints "U+E844" and "U+E863" not represented in Chinese font pack...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-chinese-zysong (Show other bugs)
5.1
noarch Linux
low Severity low
: rc
: ---
Assigned To: Caius Chance
QE Internationalization Bugs
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-09 15:48 EDT by Dan Cummins
Modified: 2010-10-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 00:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of how the characters look on RedFlag 5 (Chinese Linux) (15.57 KB, image/pjpeg)
2008-05-09 15:48 EDT, Dan Cummins
no flags Details

  None (edit)
Description Dan Cummins 2008-05-09 15:48:29 EDT
Description of problem:

For the unicode codepoints "U+E844" and "U+E863" (designated as private use 
characters) no glyphs are provided in any of the truetype fonts provided with 
the Red Hat Linux distribution.  This means Java applications attempting to 
display those characters, will not be able to.  The characters in question are 
Simplified Chinese characters and are available in the Red Flag (Chinese Linux) 
distribution as part of their zysong.ttf (DongWen-Song) font.

We would like to request an enhancement that glyphs for these codepoints be 
added to the truetype fonts provided with the Red Hat Linux distribution. I 
have attached a picture of what the glyphs look like on RedFlag.


Version-Release number of selected component (if applicable):

I tried installing the latest fonts-chinese-zysong-0.1-5.el5.noarch.rpm package 
as per Advisory: RHEA-2007:0833-8 and I am still seeing the same problem.

How reproducible:

Always and easily by viewing the font in a Character Map application

Sample steps to Reproduce on Windows:
1. the latest fonts-chinese-zysong-0.1-5.el5.noarch.rpm package on Linux
2. copy the ukai.ttf / uming.ttf files to a Windows machine
3. drag-and-drop them to C:\Windows\Fonts to install them
4. open Programs->Accessories->System Tools->Character Map
5. change the Font being viewed to either one of the AR PL fonts just installed
6. try to scroll to codepoint U+E844  and U+E863; they will not be there

Actual results:

Codepoints U+E844 and U+E863 will not be represented in the font

Expected results:

We had hoped that there would be glyphs for these two codepoints

Additional info:

I have attached a picture of what the glyphs look like on RedFlag.
Comment 1 Dan Cummins 2008-05-09 15:48:29 EDT
Created attachment 304982 [details]
picture of how the characters look on RedFlag 5 (Chinese Linux)
Comment 2 Caius Chance 2008-05-11 19:41:00 EDT
Hi Dan,

Which font are you talking about? You are mentioning zysong.ttf in RedFlag but
the reproduction procedures is testing on cjkunifonts.

If you are reporting to zysong, the procedures should be:

Sample steps to Reproduce on Windows:
1. the latest fonts-chinese-zysong-0.1-5.el5.noarch.rpm package on Linux
2. copy the *zysong.ttf* files to a Windows machine
3. drag-and-drop them to C:\Windows\Fonts to install them
4. open Programs->Accessories->System Tools->Character Map
5. change the Font being viewed to either one of the AR PL fonts just installed
6. try to scroll to codepoint U+E844  and U+E863; they will not be there.
Comment 3 Caius Chance 2008-05-11 19:48:32 EDT
Confirmed bug is reproducible by gucharmap. Checking if those 2 codepoints are
under GB18030 standard.
Comment 4 Caius Chance 2008-05-11 20:00:37 EDT
Hi Dan, I could not found the current GB18030 standard book. Could you provide
where is the standard book available so I could look into it. Cheers, Caius.
Comment 5 Dan Cummins 2008-05-14 16:49:17 EDT
I found a couple of references.  The best reference I found to show that those 
characters are in gb18030 is Converter Explorer by ICU:

http://www.icu-project.org/icu-bin/convexp?conv=gb18030&s=ALL

It lets you view all code pages known to ICU.  If you go to the link above, 
click on the link for GB18030, you can drill down into all the code points on 
the code page.

I used the following reference to find the code points in GB18030 that 
represent U+E844 and U+E863 :

http://www.sfr-fresh.com/unix/misc/libiconv-1.12.tar.gz:a/libiconv-
1.12/lib/gb18030.h

U+E844 is gb18030 codepoint 0x8336CD30 and can be seen with converter explorer 
by going here :

http://www.icu-project.org/icu-bin/convexp?conv=gb18030&b=8336CD&s=ALL#layout


U+E863 is gb18030 codepoint 0x8336CF39 and can be seen with converter explorer 
by going here :

http://www.icu-project.org/icu-bin/convexp?conv=gb18030&b=8336CF&s=ALL#layout

Comment 6 Dan Cummins 2008-05-14 17:04:23 EDT
There is a good list of "external links" for the authoritative specs on gb18030 
(best I could find) at the end of this WikiPedia article:

http://en.wikipedia.org/wiki/GB_18030
Comment 7 Jens Petersen 2008-05-15 03:03:33 EDT
How you tried any of the WQY fonts?

Basically the Supplementary zysong font is proprietary and as such
unsupported by Red Hat.  Any missing codepoints would have to be
resolved by the vendor, I believe.
Comment 8 Dan Cummins 2008-05-15 10:50:39 EDT
After you suggested it I went to find the WQY fonts, downloaded and installed 
them, but they were not TrueType fonts, they were bitmap fonts.  I was looking 
for TrueType fonts because Java applications can pick those up.

The problem report is really that the "out-of-the-box" Red Hat does not have 
support for the above Chinese characters.  There may be more.  It does not 
really matter to me which font I have to use, as long as it includes more code 
points.

If you can direct me to a different free font (like those WQY fonts) that is a 
TrueType font, and that includes more codepoints that Red Hat does, then we can 
just recommend that to our customers as well.  It would be better though to 
provide an improved font with the OS.

When I applied the fonts-chinese-zysong update it seemed to replace the 
zysong.ttf with some new ttf files; namely ukai.ttf and uming.ttf.  These 
appeared to be a major improvement.  

Are there any other fonts that come with Red Hat, or are available free, that 
you can recommend that would cover more code points?
Comment 9 Caius Chance 2008-05-15 20:39:53 EDT
(In reply to comment #8)
> After you suggested it I went to find the WQY fonts, downloaded and installed 
> them, but they were not TrueType fonts, they were bitmap fonts.  I was looking 
> for TrueType fonts because Java applications can pick those up.

There are more than WQY fonts available on the official website. Afaik most of
them are TrueType fonts.

> > The problem report is really that the "out-of-the-box" Red Hat does not have 
> support for the above Chinese characters.  There may be more.  It does not 
> really matter to me which font I have to use, as long as it includes more code 
> points.

The main feature of the zysong is it is a font which conforms GB18030. This
standard is currently a mandatory requirement for a operation system to be sold
legally in China.

IMHO even I take your assumption that WQY (there are more than 1 WQY so a bit
ambiguous to call it just WQY) includes more glyphs than zysong, very unlikely
WQY could be a superset of GB18030 standard. Otherwise, RHEL has no reason to
include zysong in order to make the OS be certified as meeting GB18030.

> If you can direct me to a different free font (like those WQY fonts) that is a 
> TrueType font, and that includes more codepoints that Red Hat does, then we can 
> just recommend that to our customers as well.  It would be better though to 
> provide an improved font with the OS.

Personally, you could try also installing some other TrueType fonts of WQY,
uming.ttf, and even any fonts you have found for a better coverage of
codepoints. However, please be aware that all these activities are not
guaranteed to work and not supported by Red Hat.

Furthermore, it is not recommended to use any codepoints in any business/formal
communication with any parties within China simply because there would be
possibilities which certain beyond-GB18030 codepoints could not be readable on
the other side. Hence, Red Hat is not responsible to any lost resulted by using
any codepoints beyond GB18030 standard.

> When I applied the fonts-chinese-zysong update it seemed to replace the 
> zysong.ttf with some new ttf files; namely ukai.ttf and uming.ttf.  These 
> appeared to be a major improvement.  

fonts-chinese-zysong should not replace zysong.ttf with ukai.ttf/uming.ttf. All
of them should be still located and available in the system and either of them
are the fallback of the other.

> Are there any other fonts that come with Red Hat, or are available free, that 
> you can recommend that would cover more code points?

As answered above, afaik the font that come with Red Hat (later releases of RHEL
only, not Fedora as it is not supported by Red Hat) which covered the most
Chinese codepoints is zysong. Personally you could also try the latest version
of some WQY TrueType fonts and uming/ukai in 'cjkunifonts' open source project.

Please perform test thoroughly before making any recommendations to your
customers, since you will be the only party who is going to be responsible to
provide supports to your recommendations.
Comment 10 Dan Cummins 2008-05-16 10:31:56 EDT
I tried WQY because RedHat support asked me to.  Actually I see now it was Jens 
Petersen that asked me about WQY; all my other emails were with Caius Chance.  
I am perfectly happy with zysong if it covers the codepoints in the problem 
report.  Again, I have no attachment to using WQY, I was just following your 
(Red Hat support's) suggestion and trying to be cooperative.  It would be much 
better for our customers if we don't have to tell them to download a font that 
is not included with the OS.

Hopefully I've provided enough evidence that those codepoints are part of 
GB18030.  I am not asking about codepoints "beyond GB18030".  

You'll notice in my original problem report I pointed out that the zysong.ttf 
that comes with Red Flag (Chinese Linux) includes these codepoints and the 
zysong.ttf that I got with Red Hat does not.

Can we focus on getting me the latest zysong.ttf that comes with Red Hat?  Can 
you email it to me?  Or tell me how to get it?  Did you already look inside 
with Character Map to know that it includes the codepoints above?
Comment 11 Caius Chance 2008-05-18 21:50:51 EDT
Dear Dan,

Thank you very much for your reply.

(In reply to comment #10)
> I tried WQY because RedHat support asked me to.  Actually I see now it was Jens 
> Petersen that asked me about WQY; all my other emails were with Caius Chance.  
> I am perfectly happy with zysong if it covers the codepoints in the problem 
> report.  Again, I have no attachment to using WQY, I was just following your 
> (Red Hat support's) suggestion and trying to be cooperative.  It would be much 
> better for our customers if we don't have to tell them to download a font that 
> is not included with the OS.

I would like to inform you that I and Jens are not Red Hat Support. Therefore,
as I clarified in previous replies that my suggestions are not guaranteed to
work and not supported by Red Hat.

Furthermore, bugzilla is not the first place to request for support of Red Hat
Enterprise Linux. You should contact via Red Hat Support (Please read
https://www.redhat.com/support/process/production/) for official support from
Red Hat. Given you are holding current subscription or eligible to receive
support in any other ways, they will manage to resolve your problems or escalate
to appropriate personnels.

> Hopefully I've provided enough evidence that those codepoints are part of 
> GB18030.  I am not asking about codepoints "beyond GB18030".

The most obvious evidence you have provided is from the ICU example page.
However, all I need is a official GB18030 document which specified how glyphs of
the codepoints supposed to be looked like. Personally I searched on the Internet
but I couldn't found it.
  
> You'll notice in my original problem report I pointed out that the zysong.ttf 
> that comes with Red Flag (Chinese Linux) includes these codepoints and the 
> zysong.ttf that I got with Red Hat does not.

Would it be possible to host the zysong.ttf that comes with Red Flag online and
let me have a look on it? Please kindly be aware that it is not an implication
that we have to make zysong.ttf in RHEL covers all codepoints which zysong.ttf
in Red Flags included. All zysong.ttf in RHEL only supposed to be GB18030
conformed and it was already certified by the organization who authorized by
Chinese Government.

> Can we focus on getting me the latest zysong.ttf that comes with Red Hat?  Can 
> you email it to me?  Or tell me how to get it?  Did you already look inside 
> with Character Map to know that it includes the codepoints above?
> 

The zysong.ttf that comes with Red Hat is not distributable via email so we will
not email it to you. Please contact Red Hat Support (the link written above) for
how to get it legally. All I could confirm is the zysong.ttf currently on my
hand doesn't have the 2 glyphs mentioned by you.

Cheers, Caius.

Note You need to log in before you can comment on or make changes to this bug.