Bug 445979 - Compilation against libgphoto2 yields lt_dlforeachfile
Compilation against libgphoto2 yields lt_dlforeachfile
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-10 18:09 EDT by Dov Grobgeld
Modified: 2013-07-02 19:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-11 16:01:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2008-05-10 18:09:00 EDT
Description of problem:

When trying to install the latest hplip library I encountered an error due to
libgphoto2. Further investigation showed that I get a linkage error when trying
to use this library. Note that this is a system that has been upgraded from a F8
system, so there might be some remaining libraries that cause the problem,
though I was unable to find one.

Version-Release number of selected component (if applicable):

gphoto2-devel-2.4.0-10.fc9.i386

How reproducible:

Always.

Steps to Reproduce:

1. Create the following program. Never mind it won't do anything. Its the
compilation we are after.

#include <gphoto2.h>

int main(int argc, char *argv[])
{
    gp_file_open(NULL, NULL);
}

2. Compile it as follows:

cc `pkg-config --cflags --libs libgphoto2` -o gp gp.c

where pkg-config --cflags --libs yields:

-I/usr/include/gphoto2  -lgphoto2 -lgphoto2_port -lexif -lm -lusb 
  
Actual results:

/usr/lib/gcc/i386-redhat-linux/4.3.0/../../../libgphoto2.so: undefined reference
to `lt_dlforeachfile'

Expected results:

Nothing - i.e. succesful linkage.

Additional info:
Comment 1 Dov Grobgeld 2008-05-11 16:01:38 EDT
Oops. Found the problem, I had an old libltdl in /usr/local .

Note You need to log in before you can comment on or make changes to this bug.