Bug 446013 - e1000e looses packets after resume
e1000e looses packets after resume
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-11 22:15 EDT by Andrew Bartlett
Modified: 2009-04-01 05:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 05:34:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2008-05-11 22:15:25 EDT
Description of problem:
After a hibernate (suspend to disk), a ping to a local network host returns only
1/6 packets. 

Version-Release number of selected component (if applicable):
Linux naomi 2.6.25-14.fc9.x86_64 #1 SMP Thu May 1 06:06:21 EDT 2008 x86_64
x86_64 x86_64 GNU/Linux


How reproducible:
Every time

Steps to Reproduce:
1. Hibernate workstation
2. Resume
3. ping server.near.me
  
Actual results:
Massive packet loss

Expected results:
All packets returned sucessfully.

Additional info:

The problem is 'fixed' if I power cycle the switch (causes a re-negotiation I
presume). 

dmesg reveals:

eth0: Link is Down
eth0: Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
eth0: Link is Down
eth0: Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
eth0: Link is Down
eth0: Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
eth0: Link is Down
...
Comment 1 Bug Zapper 2008-05-14 07:00:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Andrew Bartlett 2008-08-11 00:45:31 EDT
Note that I still see this in current Fedora 9 kernels.
Comment 3 Jesse Brandeburg 2009-02-09 17:06:11 EST
can you please check to make sure you are seeing interrupts on your interface after resume

is there a chance you could run the ethregs utility before and after resume?  I guess you'll have to build it, you'll need the pciutils-devel rpm

http://prdownloads.sourceforge.net/e1000/ethregs-1.1.tar.gz

also the output of ethtool ethX after resume, and ethtool -S ethX

Thanks
Comment 4 Andrew Bartlett 2009-02-10 17:54:20 EST
I gave up on hibernate for a while, but tried it again this morning and cannot reproduce.  

I presume somehow this has been fixed in the 2.6.27.12-78.2.8.fc9.x86_64 kernel.

Feel free to close with the appropriate status.

I'll reopen this if it ever re-appears.

Note You need to log in before you can comment on or make changes to this bug.