Bug 446017 - firewire_sb2 attempting to send invalid management request
firewire_sb2 attempting to send invalid management request
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Jay Fenlason
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 01:20 EDT by Sean Bruno
Modified: 2014-08-31 19:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 13:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Bruno 2008-05-12 01:20:46 EDT
Description of problem:
It appears that firewire_sb2 is attempting to send an ORB Manangement request
with a type of 5.  This is still a reserved field AFAIK.

Version-Release number of selected component (if applicable):
2.6.18-53.1.19.el5

How reproducible:
Everytime

Steps to Reproduce:
1. connect SBP-2 firewire device to a RHEL5 machine.
2. execute a modprobe firewire_sb2
  
Actual results:
Login is successful, but a management ORB with a type of "5" is sent.

Expected results:
Not this?

Additional info:
Comment 1 Jay Fenlason 2008-05-12 10:51:43 EDT
There have been significant changes in the firewire stack for rhel-5.2  Have 
you tried using the 5.2 beta kernel?
Comment 2 Sean Bruno 2008-05-12 11:22:53 EDT
Well, no.

If you can point me at a URL to grab the kernel RPM for 5.2, I'd love to test it.
Comment 3 Sean Bruno 2008-05-27 20:25:18 EDT
Seriously, where can I get the update RPM?
Comment 4 Don Zickus 2008-05-28 10:33:56 EDT
One place to grab kernel rpms is from my people page
http://people.redhat.com/dzickus/el5

The 92.el5 kernel is the one we shipped for 5.2
Comment 5 Sean Bruno 2008-05-28 23:35:10 EDT
This error is still present in 2.6.18-93.el5 from the packages specified in
Comment #4.

Comment 6 Sean Bruno 2008-05-29 19:15:24 EDT
I seem to have stumbled on the problem.

the firewire driver in both kernels tested is work properly.

I think there was something wrong with my target as I can't seem to get it to
happen on any other target I have in the house(tried three others).

I have sent this target into the trash heap as it also fails to work with
Windows and OSX.

<move along...nothing to see here>
Comment 7 Jay Fenlason 2008-08-14 13:00:34 EDT
Closing as per comment #6.

Note You need to log in before you can comment on or make changes to this bug.