Bug 446048 - mkinitrd makes an image that fails boot when installing a later kernel while running an earlier kernel
mkinitrd makes an image that fails boot when installing a later kernel while ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 06:37 EDT by Jim Cowan
Modified: 2013-03-20 09:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 09:37:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cowan 2008-05-12 06:37:10 EDT
Description of problem:

Recently I upgraded my kernel to one of the 2.6.24 series, using an rpm, and
then tried numerous other late kernel rpms, and all gave the same results. My
investigation has shown this to be very repeatable,m and effects RHEL, CentOS,
and any other clones of eredhat and probably others as well. 

I have upgraded the mkinitrd file to the latest available to see if this might
fix it, but no joy there either. 

here is the problem as I see it:
When a new kernel rpm is installed, mkinitrd makes a new initrd image using the
new kernel, and modules as well as the hardware configurations of the machine used. 

When this image is made, if running an older kernel such as 2.6.18, as I was, &
the disks are ide, thus using the hda, hdb naming, the new initrd will fail to
boot, as the new drivers for the disks will be looking for sda, sdb, etc. Now,
it seems as this should not be a major issue, since the drives are called by
their grub names, and or labels anyway, but something is going on in mkinitrd
that causes the new initrd image o fail booting. the only way I was able to
install the new kernel and then boot it was to install the kernel rpm while
booted to a later than 2.6.18 or more kernel, that also uses the sda, sdb naming
for the ide drives.

You may, upon research, feel that this should be fixed elsewhere, but I thought
mkinitrd was a good place to start, since I feel it should compensate for the
naming changes, if possible. This issue has been responsible for a great deal of
the "kernel panic" problems on the net I have found in various forums, but the
users usually found some workaround, as I did.

I simply booted to a Fedora 8 rescue cd, and installed the kernel rpm after
chrooting to be in the disk os. 



Version-Release number of selected component (if applicable):

I tried every late mkinitrd available with the same result


How reproducible:

as above, boot into a 2.6.18 kernel, and install the 2.6.24 or 2.6.25 kernels
from rpm, and reboot. I also had this issue after compiling the alter kernels
from source and installing them.  believe if you install any late kernel while
booted into an earlier kernel, you will get the panic when it cant find the root
drive.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2013-03-20 09:37:10 EDT
While Red Hat welcomes bug reports on Red Hat products here in our public
bugzilla database, please keep in mind that bugzilla is not a support tool or
means of accessing support.  If you would like technical support please visit
our support portal at access.redhat.com or call us for information on
subscription offerings to suit your needs.

Note You need to log in before you can comment on or make changes to this bug.