Bug 446065 - error installing cyrus-sasl-sql, missing libmysqlclient.so.14
error installing cyrus-sasl-sql, missing libmysqlclient.so.14
Status: CLOSED EOL
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
i386 Linux
low Severity medium
: ---
: ---
Assigned To: rhn-dev-list
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 11:03 EDT by Jim Hart
Modified: 2017-07-05 11:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-05 11:24:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Hart 2008-05-12 11:03:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
There's an errata for cyrus-sasl, but it won't install. I tried forcing it with 'up2date', but it still fails. Here's is the terminal input and output:

-bash-3.00$ sudo up2date -i -f cyrus-sasl
Password:

Fetching Obsoletes list for channel: rhel-i386-as-4...

Name                                    Version        Rel     
----------------------------------------------------------
cyrus-sasl                              2.1.19         14                i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
cyrus-sasl-sql  2.1.19-14                requires libmysqlclient.so.14(libmysqlclient_14)


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

-bash-3.00$ 

The library was, in fact, missing, so I installed mysqlclient-dev. After doing that, running up2date for cyrus-sasl still gave the same error.

The library is there, now:

-bash-3.00$ find /usr/lib -name 'libmysql*'
/usr/lib/mysql/libmysqlclient_r.so.14
/usr/lib/mysql/libmysqlclient.so.14
/usr/lib/mysql/libmysqlclient.so.10.0.0
/usr/lib/mysql/libmysqlclient_r.so.10
/usr/lib/mysql/libmysqlclient_r.so.15
/usr/lib/mysql/libmysqlclient.so.15
/usr/lib/mysql/libmysqlclient.so.10
/usr/lib/mysql/libmysqlclient_r.so.10.0.0
/usr/lib/mysql/libmysqlclient_r.so.15.0.0
/usr/lib/mysql/libmysqlclient_r.so.14.0.0
/usr/lib/mysql/libmysqlclient.so.14.0.0
/usr/lib/mysql/libmysqlclient.so.15.0.0
/usr/lib/mysql3/mysql/libmysqlclient.so.10.0.0
/usr/lib/mysql3/mysql/libmysqlclient_r.so.10
/usr/lib/mysql3/mysql/libmysqlclient.so.10
/usr/lib/mysql3/mysql/libmysqlclient_r.so.10.0.0
/usr/lib/mysql3/mysql/libmysqlclient.so
/usr/lib/mysql3/mysql/libmysqlclient_r.so
-bash-3.00$ 


Version-Release number of selected component (if applicable):
cyrus-sasl-sql  2.1.19-14

How reproducible:
Always


Steps to Reproduce:
1. sudo up2date -i -f cyrus-sasl


Actual Results:
Fetching Obsoletes list for channel: rhel-i386-as-4...

Name                                    Version        Rel     
----------------------------------------------------------
cyrus-sasl                              2.1.19         14                i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
cyrus-sasl-sql  2.1.19-14                requires libmysqlclient.so.14(libmysqlclient_14)


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------


Expected Results:
cyrus-sasl installed without errors

Additional info:
-bash-3.00$ find /usr/lib -name 'libmysql*'
/usr/lib/mysql/libmysqlclient_r.so.14
/usr/lib/mysql/libmysqlclient.so.14
/usr/lib/mysql/libmysqlclient.so.10.0.0
/usr/lib/mysql/libmysqlclient_r.so.10
/usr/lib/mysql/libmysqlclient_r.so.15
/usr/lib/mysql/libmysqlclient.so.15
/usr/lib/mysql/libmysqlclient.so.10
/usr/lib/mysql/libmysqlclient_r.so.10.0.0
/usr/lib/mysql/libmysqlclient_r.so.15.0.0
/usr/lib/mysql/libmysqlclient_r.so.14.0.0
/usr/lib/mysql/libmysqlclient.so.14.0.0
/usr/lib/mysql/libmysqlclient.so.15.0.0
/usr/lib/mysql3/mysql/libmysqlclient.so.10.0.0
/usr/lib/mysql3/mysql/libmysqlclient_r.so.10
/usr/lib/mysql3/mysql/libmysqlclient.so.10
/usr/lib/mysql3/mysql/libmysqlclient_r.so.10.0.0
/usr/lib/mysql3/mysql/libmysqlclient.so
/usr/lib/mysql3/mysql/libmysqlclient_r.so

-bash-3.00$ uname -a
Linux atsdev.bates.edu 2.6.9-67.0.7.ELsmp #1 SMP Wed Feb 27 04:48:20 EST 2008 i686 i686 i386 GNU/Linux

cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 6)
Comment 1 Thomas "Shea" DeAntonio 2017-07-05 11:24:35 EDT
As you may already be aware, Red Hat is transitioning from the Red Hat Network (RHN) hosted interface to the Red Hat Subscription Management (RHSM) interface in July 2017. Red Hat has invested in and seen success from RHN for many years, and used that experience to build more robust technologies like RHSM. 
 
If you have not yet migrated your RHN systems to RHSM or you are a Red Hat Satellite customer, please review the information from. https://access.redhat.com/products/red-hat-subscription-management#migration. 
 
Since we are shutting down RHN, no further actions will be taken with this bug or enhancement request.  You can find additional information at RHSM product page (https://access.redhat.com/products/red-hat-subscription-management).  If you have further questions, please contact support (https://access.redhat.com/products/red-hat-subscription-management#support).

Note You need to log in before you can comment on or make changes to this bug.