Bug 446066 - rsyslog update for 5.3
rsyslog update for 5.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rsyslog (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Vrabec
Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 11:14 EDT by Peter Vrabec
Modified: 2009-01-20 16:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:42:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2008-05-12 11:14:16 EDT
Description of problem:
Problem discovered in rsyslog 2.0.0-11

- bug in integer conversion
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=7eb0a763c32c9887dd0b1523ac154757f641e27e

- potential hang in file and fwd output module
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=5abc990a6a2178bbc730a43bd0ee9b433abc8303

- invalid string handling via strerror_r
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=2dd6d08b5d4ec053095d532dc1540f6630553c9b
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=3896b8c5fe0b0058310a8135660fb74822a89ede

- suspended actions were not always properly resumed
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=3141c15442cdb669d6e5a609011e655e2b1e8815

- errno could be changed during mark processing
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=a745208787f3b2752e17d3171ca3e2a2f4f0d5c4

- trailing ":" of tag was lost while parsing legacy syslog messages without 
timestamp 
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=91b54ed246977cb961977ca400c19b6d5b107583

- misspelled config directive, invalid signal info
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=14a7c82fadd27446af318c61cb46992802a3aa3c

- bug that caused invalid treatment of tabs (HT) in rsyslog.conf
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=c96bb3660e89d4f4d45feb58d35262bb4ffca9c6

- $EscapeCopntrolCharactersOnReceive was not properly initialized
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=c73ab075e6185eb424df9c9e588de664c55a8d96

- potential segfault condition on HUP
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=b00cf838bb11fdff8a55c67f07e1045350ec8981

- not properly initialized data could cause several segfaults
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=230883321cfa7e2dea6d4e5bffe5c3a6b00883ba

- internally generated messages had "FROMHOST" property not set
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=9971f8ffd2241c9fb398a5b78bc8ed6240089cc0

- continue parsing if tag is oversize 
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=6b2f3da3b511c842465ea4d0826ea915cc1a11fe

- man/doc page typos
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=e4d08143bb6c246bf33cc6407bb61c5f3ce18391
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=cf11c5f530bde0df3cc31374dc615e4646883b48
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=366e5dcf9c96382ddccd6f094253657c8fbe4e2d
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=e14dbae80c2f0541a67f23e00c44b7bd43f85bf1
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=09d7d7d2583de936cfafa8b9452c77664b3fcdfa
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=1a4ea8dc01a946ad48a0e85808d3e09d047c98d3
Comment 1 RHEL Product and Program Management 2008-06-02 16:00:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Peter Vrabec 2008-06-26 12:04:06 EDT
David, I will appreciate if it's possible to rebase rsylog with stable upstream
release. Backporting all the issues might be little risky and it also takes more
time.
Comment 7 Peter Vrabec 2008-08-26 08:01:25 EDT
complete list of changes between 2.0.0 and 2.0.6.

NOTE: there are only bugfixes, no features, since v2 branch is in maintainance phase.


- bug in integer conversion
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=7eb0a763c32c9887dd0b1523ac154757f641e27e

- potential hang in file and fwd output module
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=5abc990a6a2178bbc730a43bd0ee9b433abc8303

- invalid string handling via strerror_r
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=2dd6d08b5d4ec053095d532dc1540f6630553c9b
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=3896b8c5fe0b0058310a8135660fb74822a89ede

- suspended actions were not always properly resumed
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=3141c15442cdb669d6e5a609011e655e2b1e8815

- errno could be changed during mark processing
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=a745208787f3b2752e17d3171ca3e2a2f4f0d5c4

- trailing ":" of tag was lost while parsing legacy syslog messages without
timestamp
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=91b54ed246977cb961977ca400c19b6d5b107583

- misspelled config directive, invalid signal info
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=14a7c82fadd27446af318c61cb46992802a3aa3c

- bug that caused invalid treatment of tabs (HT) in rsyslog.conf
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=c96bb3660e89d4f4d45feb58d35262bb4ffca9c6

- $EscapeCopntrolCharactersOnReceive was not properly initialized
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=c73ab075e6185eb424df9c9e588de664c55a8d96

- potential segfault condition on HUP
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=b00cf838bb11fdff8a55c67f07e1045350ec8981

- not properly initialized data could cause several segfaults
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=230883321cfa7e2dea6d4e5bffe5c3a6b00883ba

- internally generated messages had "FROMHOST" property not set
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=9971f8ffd2241c9fb398a5b78bc8ed6240089cc0

- continue parsing if tag is oversize
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=6b2f3da3b511c842465ea4d0826ea915cc1a11fe

- man/doc page typos
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=e4d08143bb6c246bf33cc6407bb61c5f3ce18391
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=cf11c5f530bde0df3cc31374dc615e4646883b48
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=366e5dcf9c96382ddccd6f094253657c8fbe4e2d
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=e14dbae80c2f0541a67f23e00c44b7bd43f85bf1
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=09d7d7d2583de936cfafa8b9452c77664b3fcdfa
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=1a4ea8dc01a946ad48a0e85808d3e09d047c98d3

- bugfix: QHOUR and HHOUR properties were wrongly calculated
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=0e2d246a2e07c62b692aa8ef15415fb77af921a7

- bugfix: regular expressions inside property replacer did not work properly
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=1e4963f7fb25763c8ec9b9edc4c5ffdd6a0c5409

- bugfix: IPv6 addresses could not be specified in forwarding action
  New syntax @[addr]:port introduced to enable that. Root problem was IPv6
  addresses contain colons. (backport from 3.21.3)
http://git.adiscon.com/?p=rsyslog.git;a=commit;h=6f75d5460b12d6f57b3671d71d889747da0074cc
Comment 11 errata-xmlrpc 2009-01-20 16:42:32 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0172.html

Note You need to log in before you can comment on or make changes to this bug.