This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 446105 - Installing the developer install didn't result in working IPA setup (dnsmasq not running?)
Installing the developer install didn't result in working IPA setup (dnsmasq ...
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Pevec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 15:06 EDT by Benjamin Kahn
Modified: 2010-03-16 13:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 11:23:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kahn 2008-05-12 15:06:43 EDT
Description of problem:
Installing the developer install didn't result in working IPA setup (dnsmasq not
running?)

Version-Release number of selected component (if applicable):
0.4

How reproducible:
Only tried once, and got the problem, likely happens every time

Steps to Reproduce:
1.Follow the instructions at: http://ovirt.org/devel-install.html
  
Actual results:
IPA did not get configured because DNS was set up wrong

Expected results:
dnsmasq should be running and IPA should work

Additional info:
Looks like an init script ordering problem for firstboot.
Comment 1 Alan Pevec 2008-05-12 18:28:18 EDT
ipaserver-install.log says: The IPA Server Hostname cannot be a CNAME, only A
names are allowed

IPA hostname for devel install is management.priv.ovirt.org and should be
resolved by dnsmasq instance started from ovirt-wui-dev, which is S60.
ovirt-wui-dev-first-run is S95, so ordering is correct, but we need to add a
check that DNS for .priv.ovirt.org is functioning before running ipa-server-install.
Comment 3 Alan Pevec 2008-05-22 11:23:01 EDT
And real fix was in IPA's dnsclient.py:
http://cvs.fedoraproject.org/viewcvs/rpms/ipa/F-9/freeipa-dnsquery.patch
which is included in latest IPA Fedora RPMs ipa-1.0.0-6.fc9

Note You need to log in before you can comment on or make changes to this bug.