Bug 446116 - PK with Livna enabled fails downloading metadata
PK with Livna enabled fails downloading metadata
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-12 15:52 EDT by Jason Taylor
Modified: 2008-05-12 18:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 18:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Taylor 2008-05-12 15:52:53 EDT
Description of problem: With livna repo enabled metadata download appears to
timeout when querying individual package groups from within PK.


Version-Release number of selected component (if applicable): PK 0.1.12


How reproducible: Download and install livna repo rpm, they with it enabled try
and query individual package groups in PK, downloading metadata seems to stick.
 All packages also appear to be listed under "Other". However, when refreshing
from System -> Refresh Application Lists this behavior doesn't seem to happen.

Steps to Reproduce:
1. Download and install livna-release-9-1.noarch.rpm
2. Query a package group
3.
  
Actual results:
Times out trying to pull metadata

Expected results:
Query produces package list under the appropriate package group.

Additional info: Ran a clean all, same effect, ran a clean all and removed livna
repo and PK worked as advertised.
Comment 1 Jason Taylor 2008-05-12 16:05:49 EDT
More checking, yum grouplist and yum groupinfo work correctly.
Comment 2 Jason Taylor 2008-05-12 18:49:56 EDT
rnorwood and I were unable to reproduce this, appears to be as rnorwood
mentioned perhaps a error handling of livna repo errors by PK. I tested this on
a different rawhide system and was unable to reproduce the above errors.

Note You need to log in before you can comment on or make changes to this bug.