Bug 446167 - qt cpio rename error
qt cpio rename error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 03:09 EDT by Mamoru TASAKA
Modified: 2008-05-16 07:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-16 07:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-05-13 03:09:31 EDT
Description of problem:

Loaded plugins: refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package qt.i386 1:4.4.0-1.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 qt                      i386       1:4.4.0-1.fc10   koji              2.8 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 2.8 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating  : qt                           ######################### [1/2]Error
unpacking rpm package 1:qt-4.4.0-1.fc10.i386
 
error: unpacking of archive failed on file /usr/lib/qt4/bin: cpio: rename


Version-Release number of selected component (if applicable):
To:   qt-4.4.0-1.fc10
From: qt-4.3.4-11.fc9

How reproducible:
100%

Steps to Reproduce:
1. yum -y upgrade qt

  
Actual results:
See above

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=xulrunner-cpio
Comment 1 Kevin Kofler 2008-05-13 03:15:57 EDT
Ugh, the ages-old RPM directory/symlink glitch? :-( This probably needs a 
pretrans hack or some ugliness like that.

Rex, do you still think the change to use %{_bindir} as the %{_qt4_bindir} was 
a good idea? IMHO we should revert this change, which will instantly make this 
bug disappear, and also make Qt 3 apps using qmake build again.
Comment 2 Kevin Kofler 2008-05-13 03:26:16 EDT
Actually I reverted this right now, hopefully in time for the imminent Rawhide 
push. Should be fixed in 4.4.0-2.fc10 which is now building.

Rex, if you still want this change, we'll have to find a way to make it happen 
without breaking upgrades from Qt 4.3!
Comment 3 Rex Dieter 2008-05-13 08:25:24 EDT
Wierd, I had tested upgrades locally, and it seemed to work ok for me. ??

I agree with the revert, looks like it needs more love/testing before trying again.
Comment 4 Kevin Kofler 2008-05-13 08:56:57 EDT
The build completed at 11:49 UTC, the Rawhide push starts at 12:00 UTC, with 
newRepo and stuff, this was probably too late. :-( So we probably have a broken 
Qt in the first F10 Rawhide, fun...
Comment 5 Mamoru TASAKA 2008-05-13 11:27:48 EDT
qt 1:4.4.0-2.fc10 seems good to me :)
Comment 6 Rex Dieter 2008-05-13 11:44:25 EDT
Turns out my tests worked, because that was before I relented and put in a
questionable backwards-compat symlink at the old location.  simply omitting the
symlink would work too.
Comment 7 Bug Zapper 2008-05-14 07:04:40 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Mamoru TASAKA 2008-05-16 05:29:57 EDT
No, no.. this is on rawhide (see my comment 0)

Note You need to log in before you can comment on or make changes to this bug.