Bug 446198 - /usr/sbin/ss does not show all socket states
/usr/sbin/ss does not show all socket states
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iproute (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 09:53 EDT by Tor Ake Fransson
Modified: 2010-05-14 05:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:00:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Parsing is using standart library (10.14 KB, patch)
2008-06-27 04:46 EDT, Marcela Mašláňová
no flags Details | Diff

  None (edit)
Description Tor Ake Fransson 2008-05-13 09:53:12 EDT
Description of problem:
/usr/sbin/ss from the iproute2 package does not show all states

Version-Release number of selected component (if applicable):
2.6.18-4

How reproducible:
Always

Steps to Reproduce:
1. Create a network connection to another host (e.g. telnet host 22)
2. Check for the ESTABLISHED state with /usr/sbin/ss -n
  
Actual results:
The tcp state is not shown

Expected results:
ESTAB 0 0 <your ip>:<any port> <other host>:22

Additional info:
Testing different versions of upstream iproute2 from
http://www.linux-foundation.org/en/Net:Iproute2, the problem is still present in
2.6.22 but disappears in 2.6.23. It is sufficient to replace the ss.c source
file in 2.6.18 to resolve the problem.
Comment 1 Tor Ake Fransson 2008-05-13 11:18:28 EDT
Loading the tcp_diag.ko kernel module also solves the problem - which would
indicate that the parsing of /proc/net/tcp is the problem.
Comment 2 Marcela Mašláňová 2008-05-14 04:55:27 EDT
They starting use different parsing, which possibly fix also tcp issue.
Comment 3 RHEL Product and Program Management 2008-06-02 16:00:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Marcela Mašláňová 2008-06-27 04:45:37 EDT
I've tested the upstream patch (from iproute2-2.6.23), which fixed this issue.
Comment 5 Marcela Mašláňová 2008-06-27 04:46:42 EDT
Created attachment 310413 [details]
Parsing is using standart library
Comment 10 errata-xmlrpc 2009-01-20 17:00:11 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0204.html

Note You need to log in before you can comment on or make changes to this bug.