Bug 446272 - yum doesn't install gcc on a minimal text based install
yum doesn't install gcc on a minimal text based install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Pradeep Kilambi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 16:44 EDT by James M. Leddy
Modified: 2014-08-11 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 12:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James M. Leddy 2008-05-13 16:44:18 EDT
Description of problem:


Version-Release number of selected component (if applicable):
3.2.8-7


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Issue Tracker 2008-05-13 16:46:32 EDT
This event sent from IssueTracker by jleddy 
 issue 179742
Comment 2 Issue Tracker 2008-05-13 16:47:17 EDT
This event sent from IssueTracker by jleddy 
 issue 179742
Comment 3 James M. Leddy 2008-05-13 16:51:10 EDT
 Issue:   	 Hello,

the customer faced an issue with dependencies of packages
via "yum" that prevented them to install "gcc", I'd like to
report it even if the customer is ok with a workaround
(installing some packages with "rpm").

This appears on fresh installation of a RHEL 5.1 x86_64
(i386 is ok), the steps to reproduce (I tried locally on a
VMware):
- from the RHEL 5.1 x86_64 DVD (or set of CDs), start "linux
 text"
- you can select all the defaults (English, US keyboard,
 skip installation number, default partition layout)
- deselect all the software entries and select "customize
 software slections"
- deselect all the software categories
- register it on RHN
- try to request the installation of "gcc" and you see the issue:
# yum install gcc
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Loading "security" plugin
Setting up Install Process
Setting up repositories
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.4 MB    00:02
################################################## 4355/4355
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gcc to pack into transaction set.
gcc-4.1.2-14.el5.x86_64.r 100% |=========================|  66 kB    00:00
---> Package gcc.x86_64 0:4.1.2-14.el5 set to be updated
--> Running transaction check
--> Processing Dependency: cpp = 4.1.2-14.el5 for package: gcc
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Processing Dependency: libgomp = 4.1.2-14.el5 for package: gcc
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for cpp to pack into transaction set.
cpp-4.1.2-14.el5.x86_64.r 100% |=========================|  57 kB    00:00
---> Package cpp.x86_64 0:4.1.2-14.el5 set to be updated
---> Downloading header for glibc-devel to pack into transaction set.
glibc-devel-2.5-18.el5_1. 100% |=========================| 109 kB    00:00
---> Package glibc-devel.x86_64 0:2.5-18.el5_1.1 set to be updated
---> Downloading header for libgomp to pack into transaction set.
libgomp-4.1.2-14.el5.x86_ 100% |=========================|  54 kB    00:00
---> Package libgomp.x86_64 0:4.1.2-14.el5 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.5-18.el5_1.1 for package: glibc-devel
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.5-18.el5_1.1 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for glibc-headers to pack into transaction set.
glibc-headers-2.5-18.el5_ 100% |=========================| 142 kB    00:00
---> Package glibc-headers.x86_64 0:2.5-18.el5_1.1 set to be updated
---> Downloading header for glibc to pack into transaction set.
glibc-2.5-18.el5_1.1.x86_ 100% |=========================| 144 kB    00:00
---> Package glibc.x86_64 0:2.5-18.el5_1.1 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-headers for package: glibc-headers
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers
--> Processing Dependency: glibc-common = 2.5-18.el5_1.1 for package: glibc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for glibc-common to pack into transaction set.
glibc-common-2.5-18.el5_1 100% |=========================| 723 kB    00:01
---> Package glibc-common.x86_64 0:2.5-18.el5_1.1 set to be updated
---> Downloading header for kernel-headers to pack into transaction set.
kernel-headers-2.6.18-53. 100% |=========================| 182 kB    00:00
---> Package kernel-headers.x86_64 0:2.6.18-53.1.19.el5 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-common = 2.5-18 for package: glibc
Error: No Package Matching glibc.i686

For your reference I attach a "sosreport" (please note that,
as the last step, I've just upgraded "sos" to the last
version to use the most accurate one):
- sosreport-lmacchia.1825470-207610-8f3b0e.tar.bz2

For extra reference I've attached what appears on the screen with:
# yum -d 10 install gcc
you can check:
- yum_-d10_install_gcc.txt

The workaround that I can see at the moment is:

# yum install kernel-headers
[... manually download of glibc-headers and glibc-devel rpms ...]
# rpm -Uvh glibc-headers-2.5-18.x86_64.rpm glibc-devel-2.5-18.x86_64.rpm
# yum install gcc

So the problem is here only with a reduced set of package and it's easily
workaround-able.
However I think it's important to report because this is visibile also in RHEL
5.2 beta, so it might worth to try to address it before RHEL 5.2 is out.

For 5.2 you can execute the same steps, for your reference in attach the sosreport:
- sosreport-lmacchia.1825470-556994-3efa2c.tar.bz2

The output of "yum install gcc" is slightly different now:
[...]
Error: Missing Dependency: glibc = 2.5-18.el5_1.1 is needed by package glibc-devel
Error: Missing Dependency: glibc = 2.5-18.el5_1.1 is needed by package glibc-headers

and the output of "yum -d 10 install gcc"
- yum_-d10_install_gcc_RHEL52.txt

Probably there's something particular to x86_64 architecture (where sometimes
the i386 packages are required as well) that triggers this issue. Someone
familiar with yum&c should be able to understand it.

Probably there's nothing to do on 5.1 (the CD are already out), but maybe it's
interesting to investigate if we can resolve it before 5.2.
Comment 4 James M. Leddy 2008-05-13 17:29:01 EDT
For some reason, glibc is showing up in rhn, but not showing up in yum


Installed Packages
glibc.i686                               2.5-21                 installed       
glibc.x86_64                             2.5-21                 installed       
Available Packages
glibc.i686                               2.5-18.el5_1.1         rhel-x86_64-serv
glibc.x86_64                             2.5-18.el5_1.1         rhel-x86_64-serv

Comment 5 James M. Leddy 2008-05-13 17:46:17 EDT
Take it back comment #4, glibc is not showing up in RHN.  we need to rev glibc
in RHN
Comment 6 James M. Leddy 2008-05-14 12:40:55 EDT
I've narrowed it down to the fact that the system is not registering to the beta
channel as the default.  

output of yum repolist

# yum repolist
Loading "security" plugin
Loading "rhnplugin" plugin
repo id              repo name                                 status
rhel-x86_64-server-5 None                                      enabled

Note You need to log in before you can comment on or make changes to this bug.