Bug 446305 - Allow installs to other prefixes
Allow installs to other prefixes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 20:09 EDT by Rui Matos
Modified: 2008-05-14 09:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 09:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (5.80 KB, patch)
2008-05-13 20:09 EDT, Rui Matos
no flags Details | Diff

  None (edit)
Description Rui Matos 2008-05-13 20:09:17 EDT
Hi Tim,

I've tried to fix a bit the autotools setup to allow installations to other
prefixes. Maybe there are still some things that don't work but we can fix those
later. ATM this patch allows s-c-p to run.

I've added the AS_AC_EXPAND macro from http://autostars.sourceforge.net/.

Please review!
Comment 1 Rui Matos 2008-05-13 20:09:17 EDT
Created attachment 305308 [details]
proposed patch
Comment 2 Tim Waugh 2008-05-14 09:40:16 EDT
Thanks for the patch.  I've been investigating the license of the AS_AC_EXPAND
macro, and it seems to be this:

dnl (C) 2003, 2004, 2005 Thomas Vander Stichele <thomas at apestaart dot org>
dnl Copying and distribution of this file, with or without modification,
dnl are permitted in any medium without royalty provided the copyright
dnl notice and this notice are preserved.

I'm not entirely sure that's compatible with distributing under the GNU GPL
version 2 or later, and the autostars project seems to be a bit haphazard when
it comes to licensing (see their LICENSE file for example).  I think I'd prefer
to steer clear of that code really.

I've added a class to config.py to do this at runtime using os.path.expandvars.

Note You need to log in before you can comment on or make changes to this bug.