Bug 446336 - Need FreeRADIUS Server 2.0.0 to fully support IPv6
Need FreeRADIUS Server 2.0.0 to fully support IPv6
Status: CLOSED DUPLICATE of bug 473704
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: freeradius (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: John Dennis
: FutureFeature, Rebase
Depends On:
  Show dependency treegraph
Reported: 2008-05-14 02:02 EDT by Nicole Dai
Modified: 2009-09-22 23:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-22 23:59:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nicole Dai 2008-05-14 02:02:37 EDT
Description of problem:
Got the following information from
FreeRADIUS 1.1.x does not particularly care if the host it runs on is
dual-stack. It will work just fine, but only use the IPv4 stack of the machine.
It will also transport IPv6 RADIUS attributes just fine but will NOT send
packets over IPv6.
FreeRADIUS Server 2.0.0 and greater has full support for both IPv6 attributes
and IPv6 network packets. 
The current version of FreeRADIUS in RHEL5.2 RC is 1.1.3-1.2.el5. So need at
least 2.0.0 to RHEL5.2 for DoD RFC 3162 compliance.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 John Dennis 2008-05-14 08:29:52 EDT
Nicole as you are aware we do not do major version upgrades in RHEL which this
constitutes. I very much doubt we would allow the 1.x version to be superseded
by a 2.x version, the two versions do not even share the same configuration,
upgrading from 1.x to 2.x requires manual intervention by the sys admin and thus
is clearly outside the parameters for a RHEL upgrade.

However, I could imagine a scenario where we offer both a 1.x and a 2.x package
in RHEL and if a site needs the 2.x version it can proactively install it as
special case. The 2.x version of FreeRADIUS is just making an initial appearance
in Fedora this week with the release of F-9. We have almost no field experience
with the 2.x version, although the package is ready as a consequence of being
released for F-9 so it in theory could be built for RHEL without too much

This request is going to need special consideration by RHEL product management
because it violates our RHEL policy. However, if there is a strong business need
for this I will support you by preparing the package for RHEL if you are willing
to do the leg work to petition product management and shepherd this request
through the various approval gates, So the ball is in your court, if you want
this you must first get it approved, and once it's approved I'll step in and do
the package work. Sound fair?
Comment 4 Subhendu Ghosh 2009-09-22 23:59:01 EDT

*** This bug has been marked as a duplicate of bug 473704 ***

Note You need to log in before you can comment on or make changes to this bug.