Bug 446356 - ypbind init script quits before timeout
ypbind init script quits before timeout
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-14 05:58 EDT by Robert Osowiecki
Modified: 2008-06-11 00:40 EDT (History)
0 users

See Also:
Fixed In Version: 1.20.4-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 00:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Osowiecki 2008-05-14 05:58:03 EDT
Description of problem:

ypbind makes false assumption on ypwhich behaviour: in my case ypwhich does not
wait 15 secs, but quits immediately when domain is not bound yet. In
consequence, the waiting loop consumes NISTIMEOUT in eyes blink, not giving a
chance to bind domain.

Version-Release number of selected component (if applicable):
ypbind-1.20.4-3.fc8

How reproducible:
Appeared when my networks was heavily loaded

Additional info:
Adding additional timeout seems to work in my case:

/usr/bin/ypwhich > /dev/null 2>&1
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
    break;
fi
# ypwhich has a hardcode 15sec timeout
# so subtract that from NISTIMEOUT to
# to see of we should continue to wait
timeout=`expr $timeout - 15`
# ADDITIONAL CODE
# sleep 5 sec anyway, in case ypwich returns
# immmediately
sleep 5
Comment 1 Vitezslav Crhonek 2008-05-16 06:51:24 EDT
Hi,

please read bug #443409 comments and tell me, if it helps.
Comment 2 Robert Osowiecki 2008-05-16 07:28:16 EDT
(In reply to comment #1)
> please read bug #443409 comments and tell me, if it helps.

I don't use either NM or hald, both are disabled in initscripts on purpose: this
system is meant to have static config only.

Network is configured by DHCP and VPN: the NIS server is behind VPN. Firewall
does not block any traffic on VPN.

Comment 3 Vitezslav Crhonek 2008-05-20 08:39:19 EDT
Sorry, I missed, that it's F8 bug... It's because there is race condition - if
ypbind starts very quickly, then only 10 seconds timeout is used - and this is
often not enough...
Comment 4 Robert Osowiecki 2008-05-21 08:04:22 EDT
Are you sure about the timeout length? When I fighted this bug I noticed, that
ypbind script exited almost immediately; I should have noticed 10 sec.

Please drop me a note as soon as you got a better solution than mine :)

Regards,
Robert.
Comment 5 Fedora Update System 2008-05-23 08:48:32 EDT
ypbind-1.20.4-4.fc8 has been submitted as an update for Fedora 8
Comment 6 Vitezslav Crhonek 2008-05-23 08:50:57 EDT
Hi,

Please try this update, timing should be better...
Comment 7 Fedora Update System 2008-05-28 22:42:28 EDT
ypbind-1.20.4-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ypbind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4502
Comment 8 Fedora Update System 2008-06-11 00:40:33 EDT
ypbind-1.20.4-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.